PWD Bridge I Firmware Update Issues - No Bridge now

Hello All,

I am new to PS Audio but a vivid follower of Paul on YouTube. Love him and his videos. They are very informative for audio newbies like me.

I recently purchased a PWD MKII Bridge 1 DAC. I am primarily planning to use it over the network streaming of audio files from my NAS. I am so used it from my Oppo 205. I no longer own CD transports. I have a problem and and a question to ask you guys.

I updated my PWD firmware from 2.4.3 to 2.4.6 successfully using the SD card. It is my understanding from the forums is the most recent firmware for PWD with Bridge I is 2.4.6. Anything beyond that is only meant for Bridge II.

It is my understanding that mConnect mControl is recommended method to play music to DAC via bridge. I tried it. But mControl did not recognize the bridge. So I thought I would update the firmware and see. The original owner confirmed that he never used the bridge. The bridge was on 0.2.10 firmware.

And I accessed the Bridge I using it’s IP address to update the firmware to it’s latest (i.e. 0.2.15). It started updating the firmware, but it returned with a failure message stating an error occurred during the firmware update. So I restarted the PWD and used it’s screen to go the bridge input and used the update firmware option there. It look long time but there was no progress. So i restarted it again. This time the PWD stopped showing an input option for the bridge. Bridge somehow disappeared.

I spent quite a bit of time here in the forums looking for options to solve this problem.

  1. I tried the disconnect and reconnecting everything, restarting everything (router, DAC, SD Card, Ethernet Connection). No luck.
  2. I tried to update the bridge firmware using both USB and SD cards. The PWD does not seem to update anything.
  3. I tried the rescue USB route. The PWD firmware got updated back to 2.4.3 from 2.4.6. But the bridge did not show up.
  4. I have reached out to PS Audio Support by Email. No response yet.

What do you guys suggest to resolve this problem?

At this point, I would HIGHLY recommend upgrading that Bridge I to a Bridge II. The MConnect app will not work with the Bridge I as it won’t see it as a play-to device. At this point, the Bridge I is pretty much obsolete, and I think other than JRiver, there aren’t many playback software options that will work with it. The Bridge II works with a lot more software options, ROON is my favorite, and is a lot more robust than the Bridge I was. We are more than happy to offer trade-up for that Bridge I for the II.

Thanks James for your response and reply to my email. At this point in time, I would like to use Bridge I and do a future upgrade to Bridge II.

Hopefully If I can get Bridge I problem fixed, what playback software options do I have which work with Bridge I and a NAS based music repository?

According to this post Bridge no seen, this bridge appeared 20 minutes after the rescue. I will try that tonight.

James - Let me know if you have any other suggestions. Thank you in advance.

Cool, give that a shot and let us know if it works. know the Bridge I a lot better than I do, so reach out to him if you have any questions. My understanding is that it’s a fairly simple UPNP end point. JRiver and Bubble UPNP are good options for it.

@jamesh or

I don’t think this rescue is working. The PWD is able to apply firmware updates from the SD card but it is not reading from USB Flash Drive at all.

The USB Flash Drive is 2 GB and I formatted it using FAT-16 format. I unizpped the Rescue.ub into the flash drive. After Powering off the DAC, inserted the USB stick into USB port on the bridge. Powered it On and waited for multiple hours. Nothing happened.

The USB lights up. Network connection on the bridge also shows green and orange lights. But no bridge.

I am very frustrated after trying to get this fixed for hours yesterday. How can a simple firmware failure make the Bridge disappear?

I need help to rescue this before I decide to send the bridge i to PS Audio for help.

I am thinking that it should not be this hard and I am making a mistake while trying to get this fixed.

Thank you.

Thanks for the update. Believe me, I’ve been in your shoes many times and it can be very frustrating. TJ is the guy you’ll want to speak with and he’ll be able to tell you if you’re making any simple mistakes. Either give us a call and ask for him or you can shoot him an email at the

1 Like

Thank you. I reached out to TJ by email.

Still waiting for reply from TJ.

Man, I am fairly technical. But I cannot figure this out. The PWD does not read the USB drive. I have tried every suggestions made in this forum to reset the bridge and bring it back. No luck😩

You should hear from him on Monday. I saw Scott sent you an email so you’re at least in touch with tech-support. Like Scott said, worse comes to worst, we’ll have to have one of our techs look at it. TJ might have some ideas for you on Monday though

1 Like

I sent you an email, sorry about the delay! :upside_down_face:

1 Like