Roon on new computer, nothing appears

Hi, I got a “new’’ computer, a 2014 Mac Mini. All appears fine with the Mac. Everything is as expected

But Roon; 2 things.

In the “audio” tab, there’s nothing. The only message is that there’s nothing connected. No DirectStream. But it’s connected up to my network.

And under “storage”, although my drives are listed, there’s no music found.

I tried throwing out Roon, and starting over. No.

I tried deleting the drives and re-listing them. Nothing. They’re still there, still show all the content, but only under “storage”, still no music.

I asked this under Roon support but I guess because it’s the weekend, the the only response was someone who asked about firewalls.

Anybody seen anything like this? Thanks.

Under system preferences, security & privacy, firewall - try disabling your firewall temporarily as a test. Is this the first time you’ve installed Roon or was it working before on another device in your house?

Firewalls was the first thing I tested. It was, and remains, off.

Roon has been running for several years. The only thing that’s changed is the host computer.

Please forgive me if you have done this already, but you didn’t specify whether or not you migrated your files from your old computer to the new one.

Can your new Mac mini ping the IP of your DS? Is the IP of your new Mac mini on the same subnet/broadcast domain as the DS and the NAS storage device?

My files are on separate drives. So they’re fine.

But first I did a TimeMachine backup, then installed the new Mini and did a TimeMachine restore.

Good question. I know that the green “lock light” still lights up, so I assume they’re good. But you may have identified the problem.

Can you tell me more? What should I do?

Sorry, looking for the quote symbol, I’m messing things up here.

I’m not sure if your Mac-mini is connected via wifi or ethernet cable, and I assume by ‘green lock light’ you mean the ‘connected’ light on the Apple-system-preferences-network panel. Two things you can check - 1) if you remember the IP address of your previous Roon-core device, make sure it is the same as your new Mac-mini. or 2) login to your Mac-mini, open a terminal screen, and ping the IP address of your DS (which you can get from the DS’s display screen.). The ping should go directly from the Mac-mini to the DS and not go through a router/default-gateway.

It’s connected via Ethernet. By lock light, I meant that, in the DS on the Bridge screen display, the network symbol is green.

No, in hindsight I should have noted the address. I assumed that that, too, would copy over, and there is a number in the network preferences, but I can’t say for sure that it’s the same.

When the sun comes up (I’m in LA), I’ll do the 2nd thing suggested.

This is what’s currently in there:


And the DS shows

Looks like I couldn’t ping it.



$ ping

Your MAC is and received this IP via DHCP. The default-gw for your network is This is all good. The weird thing is you said your DS has an IP of - this is the same IP that your MAC thinks should be the default-gw. The DS should have an IP of something like with a default-gw of


Shall I try changing the IP of the DS?

Don’t type the $ sign…


But this is likely your router.

So shall I try changing the IP address of the DS? Might need some help with that.

If you turn your DAC off with the switch on the back, wait for a couple of minutes, and turn it back on, it should ask (automatically) for a new IP address. After it restarts, wait a few minutes and check the IP address. If it is unchanged and/or Roon can’t find it, post a picture of your DS screen that shows the IP addresses here.

1 Like