Safely ejecting SD cards and USB sticks on Windows


#1

Many of us are probably using SD cards right about now to get Redcloud. Ted has reminded us of the importance of ejecting media properly in order for upgrades to work reliably.

On my old Win7 laptop I always had to shut down since right-clicking on the the tray icon for ejecting media never worked; I always got a message that the drive or card was still in use, even after I had shut down every app I could find. I use SD cards only rarely so I lived with it.

Just got a new laptop with Win10 and encountered the exact same problem devil_gif . I was not a happy camper and discovered that other people have this problem too (anyone at Microsoft notice this in the many years since Win7 came into the world??). I found this fix which I am posting here in case it may be useful to other PSA owners.

Open the “This PC” icon if you have one on your desktop, or open a File Explorer window and open the link to “This PC” at the left. Right-click on the SD card icon and choose eject. You may get the message about being unable to eject the card, but there is a “Continue” button which is not available if you start ejecting from the tray icon. Click “Continue” and the eject should be successful. This just worked for me with an SD card, and I got the on-screen confirmation that it was safe to remove the card. This is said to work with USB flash drives also but I have not tested it personally.


#2

Interesting. I have never had this issue with any version of Windows (now running 10).

Excellent work-around.


#3

Whenever I get the message that the drive or card is still in use I close all programs. After that pushing the F5 button -resfreshing the Explorer- almost always solves this (both in Win 7 and Windows 10).


#4

Thanks – I will try that. I have gotten in the habit of closing everything before trying to eject media, though (not that it seems to help). But who knows, F5 might force Windows to reread some bit that lets it know if any programs are running.

It’s also worth noting that my description of the “Continue” button works after all programs are closed down. I never tried it with anything still running, in which case it might not work.