Snowmass DirectStream Junior is now live

#344

Great news. From your picture in post #330, above, it looks like you tried at least ten home-burned USB thumb drives without success. What do you think made the difference with the official PS Audio USB thumb drive?

0 Likes

#345

Honestly, I have no idea. But I’m very happy that it worked. I will not use that USB stick for anything except the next psaudio direct stream jr update. Lets hope it works again next year.

2 Likes

#346

Merry Christmas DSJ owners and PS Audio friends!
Especially this time of the year we are enjoying our great sound and SnowMass came like a great gift! The sound is better than expected. I did found something (a bug?) that I haven’t experienced before. After a couple of hours of playing I had the issue that I couldn’t control the volume anymore and I couldn’t switch the unit off. Not through the software switch in Roon not with the blue on/off button. After switching off on the back the problem was gone.
A friend of mine has experienced the same thing already a couple of times with his DSJ. He did upgrade from my USB stick as he had couldn’t get the update done though. Nothing we cannot live with but it is not how it is supposed to be I guess…
Any thoughts?

0 Likes

#347

Happened to me, too. Yesterday was the second time. After several hours of listening via Tidal/Roon. Everything just froze (although music continued to play). I had to switch the DSJ off from the back. Then back in business. All things considered, it’s a minor annoyance — as long as it is infrequent.

0 Likes

#348

It’s happened a couple of times here. Pretty sure its a network handshaking issue of some kind. Sometimes you have to restart the router or switch too. Its like Roon is still playing to the network but for some reason the music doesn’t make it to or through the Bridge and the DSJr locks up waiting for the stream. Not very technical sounding but it makes sense to me. :thinking:

0 Likes

#349

I’ve had this once too, exactly as you have described

0 Likes

#350

Update to Snowmass worked, once I downgraded to Yale first. But also had the same experience of @shaft234. The DSJ indicates there is a Bridge II update waiting, but the long press does nothing more than shaft234 indicated.

Any insight as to what’s going on there? Thanks.

0 Likes

#351

The Bridge II update can be done via MConnect and your cell. Contact PS Audio for a pdf instructing how to do this if needed…

0 Likes

#352

Same issue with me too…although I was playing around with static IP addresses at the time & did have an IP clash on one attempt but once I sorted that, it just stayed at 0% for a long time so I switched it off at the back of the machine & now it says no bridge update is available?

0 Likes

#353

To add my experience.

I could not upload snow mass

I uploaded Yale

Then snow mass and it worked

SOUNDS GREAT!!

I wonder if they make you upload Yale first so you hear the difference :slight_smile:

I love PS Audio. I wish I could work there !

Thanks Ted Paul Joshua and everyone Ive had contact with, and those I haven’t…even Elk.

Drama Llama

0 Likes

#354

Thank you. That lead me to a thread dealing with this problem. But to be clear, MConnect cannot fix the problem. The dramatically similar, yet critically different, app MControl or MControl HD (in my case) can fix it. Merely open the app, tap the gear in the top left corner, select Device Setup, select the BridgeII device, and if the firmware is not the latest, and option will be presented that lets you select an upgrage, which then goes smooth as silk.

0 Likes

#355

An ironic phrase, given the calm gentle nature of llamas and alpacas.

0 Likes

#356

Sorry, I meant MControl…

0 Likes

#357

I’d add Vicuñas to that group also :slight_smile:

0 Likes

#358

And guanacos.

1 Like

#360

Sorry for your frustration. It’s never fun to have something be uncooperative. Especially on a Saturday!

Did you remember to unzip the file and remove the files from the folder before placing them on a clean USB stick?

Is the front panel logo light blinking when you power cycle it?

We can certainly get you going on Monday if not earlier through the forums.

0 Likes

DirectStream Junior Snowmass 2.01 released
#361

Hi Paul,

I was able to get it working after several attempts going to Yale and back to Snowmass 2.01. I did the exact same thing several times, and finally got the blinking update lights. I’m good to go!

Thanks,
Shahram

0 Likes

#362

Mr. Elk – I’m ready to give up. Don’t any PS Audio employees read this blog? At your suggestion I sent an email to Service…no response. I live about seven minutes from the PS Audio office so I might have to march down there with DAC and Transport in tow.

Am I the only one that still gets the dreaded SACD “pops” and loss of first note when starting an SACD? What about the DAC remote/volume bug? If it’s just me, I think my warranty expires in a few months so I’d like to get it fixed. If everyone has the same issue with the DSJr and Memory Transport I’d like to know that as well.

I realize you’re not a PS Audio employee but perhaps you could get someone’s attention to respond to me. Thank you very much.

All the best,
Todd Harris

0 Likes

#363

I suggest emailing Paul directly: paul@psaudio.com

I know Paul tries to monitor the forum, but he gets busy and there is a great deal that goes on which does not require his attention - we ramble a great deal. :slight_smile:

I know he will be distressed that you contacted service and did not receive a response.

2 Likes

#364

7 miles is certainly not a very long trip to have a face to face meeting with somebody to discuss the issue. If I lived that close I would like to stop by just to see the place. It would a thousand mile trip for me.

0 Likes