Snowmass DirectStream Junior is now live


#122

As we all know, it is common for the thread addressing a new release to be filled with a number of people experiencing problems. While the absolute number is pretty small, it always seems like a lot. After this initial flurry, things settle and we will get more impression posts.


#123

Easiest way to load your usb stick is to extract directly to the usb stick.


#124

I had no issue going to Redcloud the last time we had an update. I used the same USB thumb drive again and followed all of Ted’s steps but it kept failing - not recognising the USB drive essentially.
So I heeded Ted’s advice and installed the Huron firmware on the USB drive. Powered off and waited 10 secs’, powered on and sure enough it loaded. Then I powered off and swapped out the firmware on the same thumbdrive for the Snowmass, powered up and after a while, Snowmass appeared.
So a word to anyone who "thinks’ that Ted’s advice makes no sense, the reason he suggests downgrading and upgrading is based on his and others experience. It “shouldn’'t” work but obviously it does.
Having done a lot of phone support (software, not IT) I have seen this many times. Don’t skip a step even if you think it makes no sense. And have patience. We expect everything to work perfectly, first time, immediately these days - but sometimes they don’t.
And there’s always PS Audios EXCELLENT support network to fall back on!


#125

On subjective notes. There is an obvious difference between Redcloud and Snowmass. There is a different emphasis on the midrange which is great of recording with lots of ambience. Heaps more detail too which I really love. Bass seems more powerful - perhaps a bit fatter? The noise floor is definitely lower than Redcloud - that means less white noise but also obviously allows for more low level musical information too.
I had to do a few reboots to get the sound to really come on song. I’m really liking the new firmware but as per a lot of comments, it might need a slight change to my setup and cables to fine tune it.
Test tunes: Dire Straits So far away from me - background vocals are more noticeable and richer - more picking and percussion detail. Oddly, vocals seems a tiny bit further back in the mix - not a criticism just a difference.
Radiohead Weird Fishes: Much more hidden detail coming out here. What I am really loving is how the drummer sounds much more expressive, the cymbals and snare was there but it is much more in ernest. Ambient trails and low level fade outs are mouch longer and more detailed.
Ben Harper Jah Work: Bass is big, detailed. There is more detail in the percussion and guitar but it all seems to hang together a bit better - so you’re not hearing specific details ut the interplay of instruments.
There is a smidge more hardness in the upper midrange at the moment - that is because I did all these tests with my DSJ connected directly to my XA25 power amp. I normally run a BHK preamp but I wanted a “raw” difference between the 2 firmwares without the preamp coming into play. With the preamp in the mix, all that extra ambience and detail just gets more obvious and the midrange smooths out.

Good work Ted and crew.


#126

was having issues upgrading to Snowmass, tried everything above and multiple USB sticks, including trying to downgrade to Yale, but no matter what I did, even though I got to the logo blinking for several minutes and then stopping, it was still stuck on red cloud. Then, in addition to just flipping the power switch on the back and waiting 10 seconds, I tried unplugging the ac power cord for a few seconds, and…voila!


#127

I have a DSJ bought in June, 2018. It came with Red Cloud preinstalled. I have not done the recent Bridge II update yet.

Using my MacBook, I formatted an old Kingston OT 101 GT, 8 GB USB stick drive in MSDOS. Downloaded Snowmass to my Mac desktop. Dragged the files inside the Snowmass folder, not the folder itself, just the files, onto the Kingston USB drive. The DSJ was turned off. Inserted the Kingston USB drive into the back, and turned on the DSJ from the back, main power switch.

The DSJ thought about the Kiingston for about 4 minutes, and then started up like normal. The update from Snowmass did not work. It still said Red Cloud.

I then tried a 16 GB Verbatim stick drive, another old one, like 3 years old. Did the same procedure as above. This time Snowmass did upgrade. It took less than 5 minutes. I did not need to downgrade to Yale.

This makes me think that the DSJ is sensitive to the USB drive used.

Will give it a listen now!


#128

Finally got Snowmass loaded! I went on Ted’s suggestion and reformatted my previous non-working 1 GB Sandisk USB stick to just plain FAT and that did the trick.

I unplugged everything except power after getting annoyed at reaching behind my cabinet, though I doubt that was a factor. Unfortunately, not knowing my odds, I also went through the Yale downgrade path, so I don’t know if a straight upgrade to Snowmass would have worked.

I’m bringing some other observations to the fore that I certainly would have found valuable as a first time upgrader:

  1. When the USB drive is not detected, the PS Audio light flashes for 2 seconds and the DSJ display starts up immediately afterwards.

  2. When the USB drive is detected but the upgrade is unsuccessful, the PS Audio light flashes as expected for what I felt was less than 60 seconds. This not nearly as long as when the upgrade is successful.

  3. On a successful attempt, the first thing you should see when the display comes on after two minutes or so of flashing is “Upgrade USB” instead of the usual FPGA initialization text. I never got this message on unsuccessful attempts.

  4. Older Sandisk drives have this built-in U3 utility software on a partition that doesn’t go away with formatting and definitely screws things up (results in #1 above). You can remove it with “Method 2” here: https://kb.sandisk.com/app/answers/detail/a_id/2550#method2


#129

Tried 2 USB sticks. Doesn’t work.
Tried Yale. Doesn’t work.
Tried Huron. Doesn’t work.
Downloaded each of the 3 versions to the USB stick directly. Unzipped in disk. Deleted all but the 4 files. Never works.
Unplugged power cord and plugged the Jr. back in. Doesn’t work.
Unplugged bridge. Doesn’t work.
Formatted the USB sticks as GUID FAT 32 and just MS-DOS FAT 32. Neither works. I only have a Mac to use.

I am at a loss. I am posting this to show that this is not an easy upgrade process for some (So sorry Badbeef for clogging up the thread, but prospective customers should know that this isn’t an easy process sometimes.)

I expect a PM from Paul or Jeremy. I bought this device with the expectation that it was upgradable. Mine is not.


#130

Just finished the Snowmass update (after a failed bridge update scare).
Freshly formatted FAT32 4g drive.
First several tries the USB drive was not recognized. It would blink once on power up and nothing else.
Tried with network plugged in and unplugged.
Put the Yale files on the same USB drive and it took first time.
Erased the Yale files from same USB drive, copied the Snowmass files, power off, USB in, power on, the USB drive started blinking and Snowmass took the first time.
Go figure.
Now for the good news. Two words to describe the update. Holy. Crap.
It is a very different (cleaner, quieter, blacker, more articulate, just friggin’ better) sound. Hard to believe a change in code processing the same data can sound this much better.
Kudos to Ted and the whole PS Audio team. I’m gonna have to get by with a lot less sleep than normal tonight.
Thanks all.


#131

I agree, Snowmass sounds amazing so far. For me, the bass is an upgrade over Red Cloud, more full and fat, but in a clean way. High remain smooth, imaging is great, and the soundstage is noticeably larger and more dynamic. Vocal presentation is a bit more forward, but to no ill effect, sounds remarkable really…

Using Roon + HQPlayer


#132

tried several times with no luck. downgrade to Yale and snowman loads the first try. and i am using the same usb stick when upgrading to redcloud. really weird…You guys need to figure out what’s the problem here…


#133

Did the downgrade to Yale prior to loading SM. Went very smoothly once I learned of the Yale downgrade.
Thanks to all for your input and suggestions. Really appreciate you folks.


#134

Redcloud > Yale > Snowmass.

Clear increase in bass - had to use Roon DSP before, no more. Rumbling nicely at 17hz :slight_smile:


#135

Before going to bed I tried one more time to downgrade to Yale. This time it worked. Quickly too.

Upgrade to Snowmass worked too. Very quickly I might add. Like two minutes.

Too late to listen. But the 17th time (literally) was the charm.

So my Jr is indeed upgradable. I stand by my crapshoot statement. No reason it should have been this much of a hassle. Needs to be analyzed for root cause to avoid future issues.


#136

Might be worth finding out which brand or brands of USB devices are involved in the failures and whether or not these particular devices have any embedded software on them when shipped. Especially if that software can’t be removed.


#137

jhchernoff… Happy to hear it worked out for you!


#138

I reformatted two fairly new but previously used usb flash drives, and loaded the extracted SM files in the root directory:

Sandisk 32G SM loaded in DSJR

Transcend 16 G DSJR did not recognize


#139

Thank You ! Paul and the rest of the Team Working This Great little Christmas gift to my DirecStream Jr.


#140

Use USB Stick downgrade to Yale then Update to Snowmass work for me the first time


#141

Thank You !!! Ted downgrade to Yale then upgrade to Snowmass work perfectly for me.