Snowmass, Foobar, and adding a delay: Pregap DSP


#1

I am starting a new thread for foobar users and Snowmass who want to add some delay to avoid the volume ramp up.

There is a component called Pregap DSP that should add some time (you select in ms) when the format changes. This delay should allow the ramp up to occur, and then the music starts thus avoiding it.

It is not working for me. Any tips for getting it to work? I am running all the latest: Foobar v1.4, Pregap DSP v1.0.2. I went into DSP Manager and activated it, then checked the boxes in the Tools/Pregap DSP… restarted Foobar… nothing, no effect.

To trigger Pregap, I am playing a high bitstream DSD file from 2l, followed by AC/DC Girls Got Rythm. Jarring, yes I know. But the AC/DC tune starts immediately with no gap and therefore very much affected by the ramp up. The Pregap delay is not working and I hear the volume ramp up.

Peace,
Bruce in Philly

I started a thread on Hydrogen asking for help here: https://hydrogenaud.io/index.php/topic,116890
Get Pregap DSP here: https://foobar.hyv.fi/?changes=foo_dsp_pregap


Snowmass DirectStream Sr. upgrade - Available in the Downloads Section
#2

I kind of doubt that the Pregap’er will work well for DSD/PCM transitions, but you might try changing the “Output Mode” on the SACD page of Tools in Options from or to DSD+PCM.

On the other hand pressing pause during DSD or seeking during DSD won’t come out of DSD so there shouldn’t be a ramp while staying in DSD land. And the main complaint on the Snowmass thread is starting a CD playing, and (I think) the Pregap’er will work for that.