Unable to get the DS DAC to switch to PCM when playing a hybrid SACD on a DMP configured for Redbook playback


#1

Today while listening to hybrid SACD discs on the DMP and wanting to listen to differences between PCM playback and DSD, I discovered that the DS DAC will not cooperate when the “SACD mode” on the DMP is switched to “Redbook CD”. The DAC’s display shows that DSD is being processed, not PCM.

The cable connection between the two units is I2S. And neither reloading the SACD nor rebooting the DS DAC alters this behavior.

This is the first time I have tried to do this with the replacement DMP. I believe I recall when trying this with the first DMP that there was no handshake issue with the DS DAC when switching between “Redbook” and “Stereo SACD” modes when listening to a hybrid SACD.

Or could I be doing something wrong?

What I am noticing is that it takes inordinately long for the DMP to process any change I make to the “SACD mode” configuration. In fact, the display will lock-up for up to half a minute after entering the change and tapping the “back” arrow to return to previous screens.


#2

Two suggestions:

1 - Try ejecting and reloading the disc after any changes made to the playback setting.

2 - Try removing the HDMI cable from both units and reseating it (shutdown both units before doing this).

Good luck!


#3

Peanut Butter, I followed your suggestions. The only way I am apparently able to get the DMP to play the Redbook layer of a hybrid SACD is to disconnect the I2S cable and substitute a different digital-cable connection. According to my DMP’s display, only DSD is being read to the DirectStream DAC when the I2S cable is in place, regardless of configuration to just read RedBook.

I have also found out that even when configured in that Redbook mode, the DMP will not read the PCM layer of a hybrid SACD to a non-DS DAC as long as an I2S cable is attached to the DS DAC. This is direct contradistinction to what it is said in the DMP manual, specifically: “Multiple outputs can connect to multiple DACs if desired”.


#4

Rob, something’s not right. It should be as simple as switching from Stereo SACD to Redbook and reloading the disc - at least it is on my DMP. You might check that your DMP has the current f/w. My screen reads:

Bootloader: 1.13
Firmware: 1.94
FPGA: 1.04
Web: 1.06
Engine: 24-0507

Even if you do have the current f/w, you might consider reloading it in case something has gone a bit sideways. Have you tried a different HDMI cable?

Current DMP f/w is here.

-Pb


#5

Pb, I have the same firmware as you. Just to be sure nothing had corrupted, I tried reinstalling.

And a different HDMI cable makes no difference.

The only way I can persuade the DMP to read the PCM layer of a hybrid SACD is to disconnect the I2S connection to the DS DAC.

Also, as mentioned before, switching SACD mode on the DMP won’t allow me to return to the play-screen right away because the return-to-previous-screen icon (on the touchscreen) stays inoperative for up to 80 seconds afterwards.

Thanks for your help. Will escalate this to the support department.


#6

Good luck, Rob.


#7

I can’t get this to work either. Did you find a solution?

I have high hopes for the next firmware upgrade.


#8

I had the same problem, and I posted about it elsewhere here. Opening and closing the tray fixed it. It seems changes to SACD mode only take effect after you eject the disc. There are still unusual indications with unsupported bit rates being shown on the external non-PS DAC when the DMP is transmitting silence. Ted Smith commented on this in response to my post about it.

Time to reach out directly to PS Customer Support. They will take care of you for sure.


#9

Opening the drawer worked. Thanks!

The firmware has a lot of personality.


#10

It is not a bug, it is personality.