Vertical Blue and Magenta vertical lines on P10 display


#1

I just noticed this on one of my P10s. They are on the right side of the display. I normally have the display turned off, but do check my status often. They must be quite new.



Has anyone else experienced this issue? Is is a defect in the display?



Bob


#2

I have not seen this.



My guess is it is a display problem. :frowning:


#3
I have not seen this.

My guess is it is a display problem. :(


Yes, probably so. However, fortunately my P10 continues to function perfectly.

#4

I have a device (not PSA) with a single line of stuck pixels on the touch-sensitive display screen. It has been this way for over a year. I will not fix it as it is $100 to do so and does not bother me. The unit works perfectly.



I bet yours will also. :slight_smile:



#5

I have seen this issue with other devices, and the fix is often just re-seating the connector that attaches the LCD panel to the logic/display/whatever board. And if I go to the effort of re-seating a connector I always give the contacts a light brush of Stabilant 22, you’ll never have a problem with it again.


#6

Neat. I’ll give this a try when I get a chance.


#7

Stabilant 22 is made in Canada, available from Aviall. A 15ml bottle will last you forever. Use it on every AV connector and power connector you have.


#8
I have a device (not PSA) with a single line of stuck pixels on the touch-sensitive display screen. It has been this way for over a year. I will not fix it as it is $100 to do so and does not bother me. The unit works perfectly.

I bet yours will also. :)



Yes, works perfectly and not a concern.
:)