Why does Roon always display 'WAV'?


#1

For some reason, no matter what I am playing to the DAC via Roon, the DAC screen always displays the filetype as ‘WAV’.

When playing the same files via mConnect or BubbleUPnP - it shows whatever the file is (e.g. FLAC, AAC, MP3, etc.).

Is this happening with anyone else? Do I have some device setting that needs to change?

David


#2

For a set of file types (like the ones you mentioned) you have choice between decoding (decompressing) in the bridge or decoding upstream. If a file is decoded upstream the bridge can’t know what file type it was before it was decoded.

Based on your post I suspect that Roon is processing the audio (if only for a volume control) and hence the bridge is just seeing the resultant PCM.


#3

Yes - that’s what I figured but I can’t figure out what setting is doing that - everything I can find is disabled???


#4

Turns out this is the only way that Roon works - there is no setting to change - see below:

https://community.roonlabs.com/t/roon-seems-to-be-coding-everything-wav/33090/2