Windows 10 Anniversary Edition as a server


#1

If you use group policy settings to control when and how updates are applied and when reboots happen, Microsoft may have broken or disabled this with the Anniversary Update. The notice that “Some settings are managed by your organization” no longer appears in the Windows Update Screen, though the gp settings are still present. I have checked 2 out of my 3 machines here - in one of them the GP settings appear to still work, and in one not. Looking into that. Have a couple of workarounds if they did indeed break it.


#2

Good catch, Bob. Please let us know.


#3

No new patches yet so nothing to report; if in fact they did screw this up I will post my workaround, which is a little clunky but will do the trick. There is rumored to be another big patch coming on the 13th, but there may be smaller ones sooner than that.

Assuming that one does not have the group policy settings enabled, or if they now no longer work, they now have the option to not reboot during 'active hours", but in a genuinely impressive act of stupidity, they only let you set ‘active hours’ for a maximum of 12 hours per day, because as we all know, no one ever needs their computers to not be restarted for more than 12 hours of every day. (Note: I have been a Microsoft MCSE since pretty much right when the program started, which is a LOT of years ago now, and this qualifies as one of the most ridiculous things they’ve ever done, though it is also easily fixed.)

All in all, word on various forums is that they’ve really screwed up a lot of stuff with this update…


#4

Sorry for the delayed update here, had a disk crash and a vacation. :slight_smile:

Anyway: Looks like the various group policy settings that control how Windows Update behaves still work, which means that effectively it’s not difficult to keep a machine you’re using as a server from rebooting when you don’t want it to. (To get to these settings, run gpedit.msc, click on Local Computer Policy, Administrative Templates, Windows Components, and finally Windows Update.)

Additionally, as of this morning’s update, it looks like if you set the Active Hours in Group Policy Editor it now lets you set them for longer than 12 hrs/per day, though I haven’t been able to test if this actually works, and the text in the group policy option still says it’s limited to 12 hours. So either they have a bug in the interface there or they forgot to edit the text, I am not sure which. Also, it seems that all my screwing around with group policy settings has caused the Active Hours interface to go missing from the Settings app; it doesn’t return when I neuter out all the GP settings, but I see this as a non-problem as long as one can do what one wants via Group Policies.

Edit: The GP settings only work with Win 10 Pro and Enterprise, but I believe the same can be done with registry settings with the Home edition. I will document the choices once I get time to verify that they all work :slight_smile:

Edit no 2: The “Active Hours” setting has also disappeared from the Settings App in a second machine subsequent to yesterday’s patch. Still in Group Policy Editor though. One wishes that they would make up their minds, or document things a little more clearly.


#5

Yet another update (hey, they keep changing this thing on us. :))

The Group Policy settings to prevent your machine from rebooting on you have been working fine for me, but as an FYI I also just heard that as of build 14942, which is being released to the fast insider ring now, the Active Hours setting will allow you to set up to 18 hrs per day as hours in which no reboot will occur. I am not sure how long it will be before they release this build to the world at large; I’d guess a few weeks. In any case IMHO this will pretty much solve the whole reboot problem for anyone using Win 10 Pro, Enterprise, or Education editions.

It’s probably a good idea, if you intend to build a server running Win 10, to get one of the above versions instead of Home, though you can probably accomplish what you need to in Home with registry settings.

I have a friend, actually one of my very first private computer clients from 25+ years ago, who is now a professor of computer science. we got into a conversation about Microsoft in which she maintained that they only hire the smartest people. So I offered this whole Active Hours thing as proof of the contrary (in that, believe it or not, there are actually people who might not want their machines to reboot for more than 12 hours at a time!! Imagine!) So then she looked at me and said “Well, they hire the smartest people and then they don’t listen to them.”

Whatevs. :slight_smile: