DirectStream DAC upgrade to Sunlight - Blinking Light Long Time

I am attempting to upgrade my DirectStream DAC. I ordered the sunlight bit from PS Audio… shut off my amp, the DAC in the back… inserted the card I got from PS Audio… DAC is blinking like instructions say but it’s been a couple hours now… ?

Not sure what I should do - if I try to restart the DAC if the upgrades hasn’t successfully finished will it brick my DAC?

It should not brick the dac as it seems the software never completed the download to the internal memory. The new load does not take effect until the dac initializes. If you have an sd card with an earlier version of software power off the dac remove the sd insert the other and try to reload the dac again.

I do not have an earlier card but I could try to make one.

I rebooted and nothing comes up on the DAC at all… eh new PS audio amp coming tomorrow too was looking forward to… probably shouldn’t have tried to upgrade… although I bought the card from PS audio direct and the prior load was put on with in boulder so I thought it would go smooth…

Contact PS Audio and request the send you a recovery force load. They can send it via email or most likely on an sd card for you to use. It will wake up your DAC. They may send you another sunlight update card too.

It really is not that difficult to download firmware from the website and extract it to an sd card. I have even created my own force load version by editing the loader file.

I tried to build a Windom disk using etcher (I’m on a Mac)… it builds fine but when I put it in the DAC it lights up for a second and then doesn’t do anything… the DAC goes dark…

If I put the sunlight card back in it starts flashing just like it did and never seems to finish…

Is everything disconnected from the DAC?


I am a PC user and not familiar with mac. I am sure though they have a program that extracts the file the way Windows does. If you give PS Audio a call they can send you and uncompressed load file that you can copy to an sd card hopefully it will load fine and get you back on track. There must be something wrong with the sd load card you received from them. It only takes a few minutes to load the new firmware into the dac normally.

What happens? Does the screen stay completely blank and the logo light flashes? Does the DAC appear to initialize?

I did disconnected everything from the DAC… even tried unplugging for a few minutes.

When I tried to the prior version Windom… the LED would flash for a second and then go blank with no blinking light or anything…

So I created a recovery force load card from the files on the web… This allowed the DAC to initialize (whew) … and when I checked versions - it had Pike on it…

After this I tried the same original card with sunlight on it and it worked! I have no idea why it gave me such a fit - if something got corrupted?

Thanks for everyone support on this!


Excellent news!

Once in a while these quirky things happen.

Glad to hear you got the dac up and running again. It is a terrible feeling when something like that goes on. I wonder what caused it in the first place.

He said he finally disconnected everything from the dac and then it worked. This has been a known issue for some time.

1 Like

Anyone using devices other than PS Audio connected via I 2s seem to be the ones having this kind of issue. This includes Matrix devices and transports modified to connect that way. Some devices feed 5 volts back into the dac.