DMP 3.07 firmware released

Problem…, don’t know what. Loading software 3.07 try to play a disc won’t play reading it says. Software back to 3.06 it works, back to 3.07 one cd played another one not. Reading on the screen. Back switch off and on one or two cd’s playing than it’s reading and that’s it. When I put the backswitch off and on the ps audio logo starts blinking think that’s wrong. Have 3 sd cards all the same behaviour. Tried FAT16 en FAT32 same problem. For now back the an older version. Strange…maybe download the files again??? anyone knows another step to follow??? 3.06 don’t have these problems, plays the CD and DSD. Must be something with the software, when I have loaded 3.06 played a cd, stop and put the backswitch off an don the PS AUDIO button doesn.t blink. Which is good software is the same, 3.07 blinks when I do the same. Think the software is not good loaded into the DMP. Don’t know why??? Maybe someone who has a good working 3.07 machine could send the files, That worked for Dirk a few weeks ago.


Yes - I did experience problems with the 3.06 downloaded files and indeed the beta files loaded perfectly - why I simply don’t know ? I was apprehensive about upsetting the apple cart loading 3.07 due to the initial bad experience with 3.06….3.07 loaded flawlessly !!

I always use brand-new cards. It makes it easier and quicker to compare and, with a new card, there is zero chance of any residue getting left behind like there could be with a previously used card …

If I had your issue: I would load a fresh batch of files to a new and formatted card. You have done it before so you know the procedure. After the files have loaded and the DMP initializes check that it says 3.07: then, switch of the rear switch - pull the card back, switch back on, and after initializing – switch the DMP back off and give it a second reboot. I have been caught out a few times with DS updates hence required 2 reboots so I just do it now as a matter of course with all updates…

That said, I still had said issues with 3.06 downloads, but for why, I just don’t know ! Computer technology is fickle thing - plus - ghosts in the machine !

…If you still experience problems you will have to get P S Audio to send you files…

Have done all the tricks, new card only the DMP files, two reboots but after playing a part of two cd’s putting in another one it says reading and that’s it. There is nothing I can do. Only eject. So 3.06 is my software for this moment. CD’s CD and SACD with 3.07 that will not play, play flawless with 3.06. I did try redbook only but same behaviour. I will contact PS Audio coming monday. Maybe they have a solution. When I eject the not playing cd I see for a short moment the songtitle / bandname of the last played cd that played. And when it’s reading and I press play there is no title or name. Looks like it doesnot read the TOC. Other software versions don’t have this problem. They have the wellknown problems…


Weird… How your DMP functions with 3.06 but buggy with 3.07. You might have to get force-load files. Similar scenario with my DMP - but my issues were with 3.06 not 3.07… ?!

Glad it worked for you. Can’t wait to read what you think.

Email me directly and I’ll send you a new SD card with 3.07.

1 Like

Very nice update. Listening to the Rite of Spring and Petrouchka (Bernstein), and it sounds fabulous on the dmp/ds combo powered by a p5.
Thank you Paul and PS Audio!

Thanks for letting us know. I see not too many have yet downloaded it but perhaps in a bit. Definitely worth doing.

So for clarification–

With data discs, only the root directory is playable via remote control. Sub-directories can only be accessed by touch-screen.

I won’t be able to start experimenting with 3.07 until this evening, but I really hope all my data discs are burned to root directories because, other than for opening and closing the disc tray, my touch-screen is completely unresponsive to touch and has been this way for about 6 or 7 weeks with no fix in sight.

1 Like

Indeed. I never thought cds could sound so good !


The touch screen should be easy to calibrate if it has a problem. Have you contacted us? We can walk you through the process in 5 minutes.

Yes, I’ve done forced reloads, multitudes of screen recalibrations and also the recommended plugging the DMP directly into the wall socket rather than my surge protector.

None of these have worked.

All of this applies to the same issue with my DS.

What? Neither your DMP nor your DS touch screens work? That’s nuts. Please arrange with us to get them back and we’ll fix them immediately.

I’ve known that sending them back is the next step but going through that process again, leaving me without my audio system for a week or more, for the fifth time in the past 8 months is something I’ve been dreading and putting off.

Paul–I don’t know what they did to make it sound better, or even if it’s just a happy accident, but here on day 2 and it definitely sounds better. And as a person who puts a cd in and plays it to the end, it’s a gem.

1 Like

Just downloaded…Will see what the outcome is after some time in this weekend.

Same here. I hope that’s fixed in the next release. PITA to have to access touch screen to get to sub directories.

At least data discs play again. :+1:

1 Like

3.07 get rid of “clear SS” in set up menu ?

I didn’t realise you had the same fault condition with both the DMP & DS. That is more than just bad luck ! Yes, it will be a big pain being musicless, but you really need to get it addressed . I feel your pain !

DMP will not play with new software, see earlier message. I gave it a go this evening but no luck.
I tried a few times to load 3.07, loading goes fine but it played one cd, next cd don’t go throught the reading process. Reading, it says the only thing I can do is ejecting the cd and try one more time but no luck. When I put the backswitch off and on it starts blinking, meaning the software on the card versus software in the DMP is not equal. Card out, off and on, there is no blinking. loaded 3.06 again, after that when I switch the DMP off and on there is no blinking just intializing, So it must be something in the software my DMP versus 3.07
I use 3 SD cards formatted FAT32 with the new software.