DMP 3.07 firmware released

Ronald,
Have you tried reloading 2.06 and then going back to 3.07?

No, I have not. 2.08 is what I have. See it’s in the old software batch on the PS Audio site . Downloaded and I give it a try. I did, 2.06 went well back to 3.07 and I had one cd which stays in reading Elvis Costello. But when I press play the cd started. Tried around 8 cd’s and SACD’s to see and hear if they played and they did. With cover. Will try a few others,hope it stays the way it is now. Thanks JeffofArabica for your suggestion. Reading around 11-12 seconds. Tried Rush with moving pictures Stevie Ray Vaughan but no play Reading. So I go back to 3.06 and ask support PS Audio.

Ronald

Works fine for me.

One thing I still notice, and not sure if a problem for others, but it still takes multiple presses of “Play” on the remote for the loaded disk to start playing.

Loaded fine. Played all 15 tracks of Al Green on his Greatest Hits CD. Dmp display hung on 15. Hitting play, track 1 plays (as I believe it should). This is more a display issue. Screen then showed 1 as it played.—

I think there’s a delay and multiple presses restarts the process each time, making it seem slow. There’s definitely a pause briefly before it plays. But I’m guessing.

I appears you are correct. I just clicked once and waited. It took about 4-5 seconds, but sure enough it started playing. Thanks for the suggestion on that. It is strange as the delay doesn’t always happen. Sometime when I press play, it actually responds quickly.

Sure and getting a lot of pops/clicks when pressing play initially or after a pause on an SACD. Didn’t notice those in 3.06.

Here as well. More responsive than 2.08 but less than 3.06 (which I didn’t really use since it didn’t play data discs).

I find that an issue too. the read went from 4 seconds in 3.06 to 11 or 12 in 3.07 and it is still not ready to play at that point in another couple of seconds you can tell it what track you want to play. Yes I no longer hear a splash of sound at the beginning of track one but i did hear a splash when i stopped play mid track to change the disk.

Loaded 3.07 on memory card after deleting old 3.06 items. Loaded up and works well. Plays cd and sacd and usb stick flawlessly.

I suggested a possible hardware cause for the widely different experiences elsewhere, earlier on and found it strange nobody commented on it - if at least to say that they think I’m nuts.
Basically this theory goes like this: I seem to recall that an “in the field” Oppo DVD replacement is not recommended because of a certain amount of “special fine-tuning” required by/with specialized personnel/calibration equipment?? [I stand corrected …].
IF SO: Could not the degree of fine-tuning have something to do with it too?
I keep on thinking there must be a parameter outside of the software domain contributing, else I’m stuck in the realms of the supernatural to which I’m atheist.

I really like this version. Did not like last two. Stuck with 2.06 until now. This is very good. Only issue is DMP froze a couple of times. Had to reboot. Working flawlessly since. Don’t care about load time. I only play discs, so don’t know about other functionality. All good for me. Thank you all!

You’re probably right. I had ongoing DAC issues. Distributor fixed it. Now great. I think something may happen in loading new firmware a number of times. Also, how files are loaded, reformatting of SD Cards, card capacity etc all play a role. It’s not always as simple as assumed.

I just installed 3.07 from 3.06. I deleted all 3.06 files and replaced with 3.07 files. Upgrade worked fine for me.

The only problem I had is that I couldn’t test everything because I got wrapped up in the SQ.

Maybe its my imagination but I hear wider and deeper sound stage as well as more ambiance. I also noticed more space around instruments - greater dynamics as well. I listened to the portuguese Brasileirinho with Maria Bethania. This recording has incredible dynamics. I wonder how the massive bass would sound on Paul’s magnificent IRS’s.

I’ll get back to it tomorrow and test out functions.

Thanks Paul.

So my reaction so far to 3.07 is mixed and still leaves me hoping for improvements to come in a future update.

Two outstanding unresolved issues:

  1. Out of 2 data discs I tried, one played just fine and the other (which was burned using the same brand of DVD+R and the same disc burning software with the same settings) would not play at all but would merely indicate “changing directories” with each attempt. (Without touch screen responsiveness with my DMP I can’t attempt any search for sub-directories).

  2. There is an increase in the amount of pops and snaps at the start of play with SACD’s.

Unlike others, I hear, if anything, a mild decrease in detail and vividness in SQ with 3.07.

3.08 anyone??

1 Like

One more try, loaded old versions of software like 2.06, 2.08 3.06 all worked but not 3.07, Some cd’s play reading time around 11-12 seconds but others like Elvis Costello, Stranglers and Rush will not go through the reading process. With 3.06 it takes a few seconds and even the cover was shown. Older versions take a little longer reading time but all the cd’s I have tried play. Only 3.07 gives me problems. It must be a software issue because everytime I try 3.07 the PS audio starts blinking. Tried it around 5 times to see if there is improvement. Everytime blinking. Also formatted on an apple Macbook pro and window 10 machine, same behaviour. The other software versions don’t blink again once loaded. I have done all I could do. Wait till tomorrow when PS Audio is in the office.

Ronald

Also, I’m noticing that the “phantom disc” phenomenon is still happening after removing a disc from the player.

3.07 doesn’t work for me. see earlier post. When I look at the data, I got a unit number - Bootloader 1.13 - Firmware 3.07 - FPGA 104 - WEB 106 Engine 26-1125 is this correct??? Only difference is Firmware??

Ronald

Not sure what you mean about the logo blinking. AFAIK, that’s what’s supposed to happen during loading of new firmware. Mine took quite a while to load this version, but it worked eventually.

All the data you asked about is the correct data going by what’s on my DMP display.
When you play a CD / SACD are you saying the blue logo light is blinking / flashes on and off like it does during the update process ?