Does anyone like the changes to the website?

I am not happy with the look of the new website. The Power Play displays are not as good as the old version and the same holds true for the product registrations. I had such a battle getting back into the forum. I finally did but it took time and effort!


I like the new site. Yup.



1 Like

I like the increased detail of the new Power Play page.

1 Like

As advertised, load time is lightning fast. I like the look. That coming from a dude finicky about aesthetics. The product registration page? Meh. I don’t hang out on that page anyway. Have no use for Powerplay. Btw, I too was puzzled by what to do to ‘re-register’. It was never a problem when browsing with my gaming rig because, I’m guessing, I’ve never logged out. Proved to be a problem surfing the forum with my iPad. I tried to log in, but wasn’t recognized. Had to ‘register’ using my current credentials. Magically was linked with my existing account. Go figure. Anyway, challenges surmounted, back to yacking about music, gear and the everything else category of cool things I like to blab about. :slight_smile:

Is Power Play up at the moment?

I just tried to check it out and I am getting a “busy signal” of sorts.



This text will be hidden

1 Like

It is working great for me.

Not working working for me either

Works for me.

Forum working well…

But disqus registration just to read Paul’s Daily Posts that is a bridge too far!! :-1: :-1: :-1:

Best wishes

I was able to get right into the forums without any changes. To get in the rest I had to re-register which was as easy as could be. Took all of one to two minutes. I like the product registration pages. The PowerPlay section is good to, though I followed the links for setup and saved all the settings even though I didn’t change anything. Got a rude surprise when I saved the network settings, the P10 restarted, D’oh. Everything hooked into the P10 came right back up so no harm done, but it was a bit of a shock. And boy, is the website fast! Excellent!

The speed of the site is excellent.

The power play part of the website is not functioning for me. It keeps telling me I don’t have a power plant registered or my power plant is not communicating. I didn’t see a power plant registered on my account last night, so I registered it. Now, two power plants are registered, and I still get the same error.

I checked the network settings on my power plant. It has an IP address and the proper configuration to get to the internet. I can ping it and can get to its web page.

I will be patient for now, because I saw somewhere that the team is still working through some startup issues on the new site.

Welcome back. I’d suggest giving it time to allow them to sort it out. Power Play always was a bit of a crap shoot IME.

I haven’t seen it yet.

Oops, just saw it and it didn’t recognize my username and password. Bah.

Update: I was attempting to login on a machine that had been dormant for a long time. The we will email you a link to get in option worked swell. All in all maybe 4 minutes and 27 seconds of heartbreak and sheer terror! With a happy ending.

You gotta love a happy ending!

I found the formerly orderly navigation of articles in individual Copper issues was screwed up pretty badly, and it looks like the ability to comment on articles is gone. And it looks like logging in from the other “family” pages like Paul’s Post or Ask Paul requires signing in through a third party social media account, or through I service whose name I didn’t recognize.

But I sure love the speed.

I like it.

thumbs up

What happened to the Amazon Pay option at checkout ?

Should be there. Do you not see it?