DS DAC MK2 Firmware Update

Followed procedure multiple times to update 2.3.5 to 2.3.6. Ive tried reformatting / replacing USB drive… still no result. What format should the USB drive be reformatted with?

Successful on the firmware update


How did you resolve the problem ?

Re-formatted to FAT32 but may have not been the problem. Noticed the unzip was placing unzip files in sub-directory. Resaved to root on the USB drive.

1 Like

That’s the culprit.


Do I recall correctly from one of the threads that the next firmware update is expected for some time in April? Or was it for later in Q2? Who is the right person to ping at PSA to find out what will be included in the next firmware update? I find that the MK2 rejects USB sticks just as regularly as the previous model rejected SD cards. The FAT32 stick I was using suddenly was no longer acceptable. Tried some other sticks. Took an hour, but found a 10-year old FAT-formatted one that was accepted. So would be nice to get over-the-air updates working. Also want to use the power triggers. I understood from an @sixpack1 comment in another thread that these are not turned on yet…


Yes Ted has just released his, has another right around the corner. Paul has said 4/10 will be the release of the UI. I hope Ted can make that date as well.

I must be doing something wrong… downloaded the latest firmware to my Mac laptop… when unzipping the files I get an “unable to expand” error. I thought maybe I didn’t need to expand so left them zipped in the root folder of the USB stick… no dice, the unit doesn’t update.


I would try downloading the firmware again.

The files must be expanded and placed in the root directory of the USB stick. There will be two files, one for the FPGA code, and one called “image.bin” with the UI.

There was some discussion in another thread with Mac users who had some trouble unzipping the firmware. I’m not a Mac user, so I didn’t keep track of the thread; probably someone will be able to point you to that discussion.

Try un-zip at ROOT level on USB stick. Un-zip likes to create sub-directory. DAC wont pick that up. That’s where I went astray. Maybe it will help.

Welcome, @matthew.rond!

Thanks! @Elk

Thanks for the suggestions. I’ve redownloaded to my desktop and directly to the USB stick with no luck unzipping from either location. I’ll keep looking into it… thanks again!

Try right clicking the zip file, then “open with” and choose the Archive utility.

It will be interesting to see exactly what functionality will be available with the UI load that is supposed to appear today. I hope that the de emphasis will funtion properly. It would be nice to see the ability to turn off unused inputs. Balance controlled via the remote. Also better options for input naming. We shall see!

1 Like

OK, since I am east coast and about to head home from work, I will be first to complain where is it…

I think there’s already a line.


Closed, duplicative thread.