DS Sr. volume keeps resetting to 50

USB input; Roon set to fixed volume, but also happens when set to device volume; the DS Sr. volume keeps jumping to 50 (from higher values) a few seconds into listening at higher volumes. Tried turning off the unit completely and restarting. Tried pointing the remote control away from the unit. Can’t get it to stop this behavior. Please help.

Go into the setting from the front screen and when you pick the volume you want put it on fixed instead of variable.

1 Like

I’d like to retain the volume adjustment functionality…

I tried turning it off all the way (front switch and back switch) and then unplugging the power cable (and the USB cable, too, for good measure) for about 30 seconds. So far, that seems to have done the trick.

1 Like

I tried your solution. But that didn’t work for me. VERY frustrating!

Whenever you remove power from the DAC we designed it to always come back at 50 on the volume so you don’t blow your speakers in case it was a mistake turn off or loss of power. Probably not the best decision we ever made since most people use it with a preamp.

I think it is a good, precautionary feature to have included. Once you understand what is happening and have established the volume levels you prefer on the DAC (and/or Preamp), its not much of a nuisance and it serves as an indicator that power was interrupted at some point (not a bad thing).



No Paul, my dacs go to 25 which is brilliant since I once blew a £400 tweeter. It has to remain an option IMO.

My Dac also goes to 25.

But mine always goes to fifty even without power interruption. I’ll move it to 85 for instance, and ~20 seconds later, it reverts to 50 on its own.

Yeah; not normal…seek device help from PSA and /or rogue dealer.

Good luck.

Hello did anyone find a solution to the problem?
I a repair necessary, how much does it cost?

You’ll want to go into the settings, setup, then where it says level, make sure it’s locked. All this does is prevents the level button on the remote from engaging the 20dB attenuator. This will stop it from dropping down to 50.

Hello Jamesh,

thank you very much for your reply.
Won’t I lose the preamp function if I set the volume to “locked” in the setting?
Do you believe that the remote control is the reason for the volume going back to 50 automatically from any set volume?
Could it be an OS issue? I updated to Sunlight in August.

Looking forward to your reply.


No, the volume function will still work. For that to stop working, you set the fixed volume setting to fixed. It is not a remote issue. It’s a simple OS bug with this simple fix.

Hi Jamesh,

thank you, will the remote volume control also still work?