DSD Bridge 2.8.8 not "certified"


#1

I am using the DSD and Bridge II (2.8.8) as an playback device using Roon. It was working until I had to change the server that was running Roon. Once I did, the DSD came up as CDMCM-210 and is flagged as “Uncertified”. Everything works until I look at the DSD setting. There is no option to play DSDs directly, instead it converts everything to PCM.

I had seem some threads that said this was caused by firewall interference, so I turned off my firewall and reinstalled Roon. It seemed to have no effect.

What should I do?


#2

Is this still happening? What box was the old server, and what box is running it now? Are these Windows boxes? If so, what versions are you running? I gave up on my Win box as Roon server for these very reasons.

Do you have a switch or router between your Roon server and your DS? What type, etc.?

Do you have the luxury of going back to the previous box for Roon? I know that can be a PITA. I used to see this happen with my Totaldac, but I wrote that off to the gradual firmware evolution by which Vincent made the Totaldac Roon-ready. Once in a while, I saw my DS/Bridge indicated as uncertified, but that never seemed to have impaired DSD playback. That’s the oddity for me here.


#3

What version of DS code are you running? It needs to be Torreys or it won’t show as certified. It sounds like this is some kind ofr Roon/Server issue, so verify the versions.

Dennis


#4

Now and then I like to switch between different codes and sometimes after a reboot my DS/BRIDGE also is recognized as CDMCM-210 as renderer in BubbleUpnp. However the DS seems to work fine (no Roon here) I like to be sure of that and want the right name of renderer in Bubble. A complete new reboot of my gear always solved this.


#5

Thanks for all the input. I’ll try and answer some of the questions:

I am running Torreys. Looking at the display, it says Torreys, Firmware 1.8.8, Bridge 0.0.0 (which I understand is normal for this version of 2.8.8).

It was running under Windows 10 on the previous computer (i5 CPU), and is again under this one (i7 CPU). There is a wireless d-link router running on my LAN that is providing 802.11g to a Cisco/Linksys Bridge, connected to the DSD.

No, I can no longer run it on the machine it was on previously as it is being sent somewhere else.

As to the CDMCM-210. I believe that when I first installed the DSD/Bridge II on my network using J River, it came up like that, but then it changed when I updated to Torreys and installed Roon. Direct playback of DSD files via the bridge also worked. Once I reinstalled it on new computer, the option for converting (or not) to PCM is not available – it just assumes conversion and only has the PCM filtering settings available.

BTW, it sounds great. It also handles hi-res files fine. It just doesn’t allow direct playback of DSDs.


#6

Try turning off your firewall on the new computer, then reboot everthing, to see if that works. If it does you will need to reenable your firewall, and find the propers posts to enable for Roon.

Dennis


#7

Dennis,

I tried that already. First I turned off all firewalls for a day and there was no change, so I turned it back on. A week later, I again turned off the firewalls, after which I reinstalled Roon (without first removing it). It reinstalled and then when I first ran it, it immediately updated itself from the Roon servers on the Internet to the current version (so I know that the install actually did have an effect). I then disabled and re-enabled the CDMCM-210 device (the only one I have for the DSD). I left off the firewall for a few days.

All of this had no effect. The next thing I am thinking of doing is removing and reinstalling Roon completely, but I really don’t want to loose my library info since I have loaded many titles from Tidal into it.

Drew


#8

It definitely sounds like a Roon/OS issue/ since it worked from another server. It sounds like you have tried everything I can think of, have you tried to Roon forum?

Dennis


#9

No, I have not posted with Roon. I was trying here first.

I will try a full uninstall and reinstall see what happens. If that fails, I will post to Roon. If I get an answer, I will come and let you know.

I appreciate your help.


#10

They might have some more things to try. Yes please let me know.

Dennis


#11

I have exactly the same problem from time to time. My other endpoint (a Meridian MS600) has always been correctly identified by Roon so I have assumed it was a DS issue.

My not exhaustive debugging indicates it’s related to the sequence in which the Roon server & DS Snr are powered up. I don’t think it happens if I power up the DS Snr first and let it acquire an IP address, then boot the Roon Server.

DS Snr is running Torreys, Bootloader 1.13, Firmware 1.8.8, Bridge 0.0.0. Roon shows a version string for the DS “psaudio_ug-r v2.7.11”.

Roon Server software is running on an Intel i5 NUC, Windows 10 Pro. Roon Server is running as a service using NSSM. This is my first and only Roon server. Unlike the OP, I’ve always experienced this issue.

DS and Roon Server are connected to a dedicated switch. The only other connection is to a network bridge so that I can control Roon via an iPad.

It’s a PITA when Roon identifies the DS as CDMCM-210 because even after rebooting everything and getting the DS identified as a PS Audio Directstream DAC, I have to enable it in Roon and enter a zone name. First world problem I know, but all that futzing about is not an ideal way to start a listening session…


#12

Thanks markus46. I definitely think we are having a similar issue. Have you ever played DSD files back directly through the system? Does it convert it to PCM, or play the DSD files directly. The easiest way to see what is played at the endpoint is to look at the DSD display, but you can also see it by clicking the little light icon (north star ?) to the right of the name of the song/piece that is playing in the Roon software.

While I did have my DSD up an running on the network before I installed Roon on the new Server, you are making me realize that I did have my previous Roon Server running when I installed Roon on the new machine. I then had to decommission (wrong term, I am sure) the old server to free up the license and allow it to be associated to the new server. I bet that was the cause of my problems. I will be able to reinstall and test this weekend. This time I will remove all aspects of Roon except for the library, although I will delete that too if I get no improvement after the first test.


#13
Drew said Have you ever played DSD files back directly through the system? Does it convert it to PCM, or play the DSD files directly.
Hi Drew,

I have no issues playing DSD files natively without conversion - when the DS is recognized as ‘PS Audio Directstream DAC’ in Roon.

I’ve never used the DS when it’s been identified as ‘CDMCM-210’, but it wouldn’t surprise me if DSD was converted to PCM in that case because Roon is not fully aware of the DS feature set.


#14

Since I resolved the problem, I wanted to leave the answer for others.

I tried reinstalling everything to no benefit. The DS kept coming up as CDMCM-210 and kept disallowing direct DSD playback. I started searching google for any instance of CDMCM-210 and found a thread in the DS Jr product area that seemed to reflect the exact same situation. The last thing mentioned in it was the owner should check volume leveling and crossfeed should equal zero. Since I know that I have one channel set about 2 db higher than the other due to come volume inconsistency in the rest of my system, I set both to the same volume and rebooted everything. That did it. The device came up as “PS Audio DirectStream DAC” and DSD played directly. It seemed to hold onto that setting after I changed it back to be 2 db higher in my right channel.


#15

That’s interesting that that was the solution. Reading the thread I suspected as such. In Mac the PS Audio Driver item in Audio Midi Devices has to be a 100% volume of DSD will not play. It’s crazy how many times this volume slider has slightly moved, for no apparent reason, and sabotaged my DSD efforts! I’ve spent hours chasing that gremlin down, trust me! NOw I know. I didn’t know this could also happen in Windows. This strangely comforts me a little little that this doesn’t only happen in Mac! Glad you figured it out.


#16

Hi, having the same problem here with Bridge II firmware v2.9.14:

Screen-Shot-2017-02-12-at-11.45.28-AM.png

Screen-Shot-2017-02-12-at-11.56.17-AM.png


#17

Are you running Torreys? If not you will get that.

Dennis


#18

Hi Dennis, yes, I am running Torreys latest/final. Thanks.


#19

It should show as certified. You might want to check the roon forum for this issue.

Dennis


#20

Hi Dennis. I agree that Roon should recognize the Bridge II as “Certified,” but I respectfully disagree that individual PS Audio owners struggling with the Bridge II “Uncertified” problem – which causes an unwanted DSD-to-PCM conversion – should be directed to the Roon forum to hunt on their own for a possible explanation and/or solution. (The proposed solution in post #14, above, did not work for me.)

I reported the “Uncertified” issue here in the hope that PS Audio might work directly with Roon to come up with a solution. I am on a one-year free trial of Roon that expires in October 2017, compliments of PS Audio, and for that I am extremely grateful. But there is no way I would pay $500 for Roon in its current state.

The DS/Bridge II tandem works very well in my system with MinimServer and various UPnP control point apps. When it comes to Roon, however, I have found the experience to be frustrating and unsatisfactory. If I had paid $500 for Roon I would be more than a little upset. But because PS Audio was so generous in allowing me to try Roon free for a year, I am simply bemused by the bugginess I am experiencing.

Also, I am so happy with the sound quality and ergonomic experience of my MinimServer-equipped Melco feeding the DS via the Bridge II that I do not see Roon in my future (at least not at anything close to the astronomical $500 price point) even if Roon were to recognize my Bridge II as “Certified.”

If PS Audio is concerned that Roon is seeing some number of Bridge II installations as “Uncertified” then I suggest respectfully that PS Audio and Roon should try to figure the issue out for the benefit of their [potential] mutual customers. If not, then thanks again to PS Audio for the Roon free trial but I will take a pass on Roon and stick with the rock-solid MinimServer and Melco. Thanks.