JRiver stops after each track from NAS to DAC


#1

Hi all,

I am testing JRiver MC20 to use in my stereo and have a problem I cannot seem to solve.

Ihave a
PSAudio PerfectWave DirectStream DAC with a PSAudio Network Bridge installed
QNAP TVS-463 NAS holding my music files in FLAC format
Both devices are connected to my 1GB Ethernet home network through a 1GB switch

I can add tracks to the Playing Now list for the DAC but the playback always stops after each track.

If I manually start the next track it will play.

Does anyone have an idea why I am having this problem?

Thanks,

Chip


#2

I have noticed that issue also with the bridge when you have Jriver set to shuffle and you try to use bubblepnp or something besides gizmo or Jremote for pushing to the dac…it also happens with my Krell Connect and Oppo 105d if I try to pull to them but if I push from Jriver it works fine so Im thinking its a Jriver Issue pulling-hair_gifpulling-hair_gifpulling-hair_gifpulling-hair_gif


#3

Using the same JRiver configuration and the same Ethernet cable, switch port, and switch I set up another network DAC in place of the DirectStream DAC.

I selected the same CD and added it to Playing Now for the other DAC and all the tracks played through from 1 through 12 without any problems.

This makes me believe my NAS and network are OK and I have a problem with the Network Bridge.
I started a new thread with the details of what I did today in my test called “DirectStream DAC with Network Bridge does not playback continuously”.

Does my logic make sense?

Anyone care to disagree? Why? Have I forgot something?

Any ideas?

Thanks,

Chip


#4

Chip,

I have the same experience with my Qnap server. Also have a Directstream DAC with bridge. So I put my database back in the Mac. The Macbook doesnot give me any problem. I am also looking for a solution. Don’t know if it’s a Jriver only problem.

Ronald

Radio Seaside


#5

What Server are you running on the Qnap? Is the the built in qNap server? If it is try it with minimserver, which install on most qnap Nas’s.

Dennis


#6

I’m not running Jriver on my qnap. TS253-pro. That is not possible (Linux) Macbook has Jriver and Qnap the database. Which is now also on my Macbook. (The music files with covers) Macbook plays without any problem all the songs throught the bridge into the Directstream. Album cover and song that is playing is shown when playing. But I had the intension to put all my music in the Qnap server and play it by Jriver on my Macbook. Maybe bridge 2 will sort it out, or a new software update by Jriver. Time will tell.

Ronald


#7
Dennis Kerrisk said What Server are you running on the Qnap? Is the the built in qNap server? If it is try it with minimserver, which install on most qnap Nas's.

Dennis


Hi Dennis,

I am running MinimServer directly on my QNAP NAS and JRiver MC20 on a Lenovo laptop. All devices are connected to the same 1GB Ethernet switch with CAT5E Ethernet cables.

I seem to have stumbled upon a ‘not so elegant’ work around:
fully power off the DAC from the rear panel switch
wait a minute
power on the DAC
after it is ready but before playing any files
use a web browser to access the Network Bridge web page
perform a Reset UPnP Server from the Network Bridge web page

I can then play my music files without sudden stops but I still experience the occasional glitch where the music seems to skip and the Album Art display is very erratic - sometimes it is there but many times it is not.

Chip


#8

This was a known procedure when eLyric was around (except for the necessity of doing a hard reset of the DAC).


#9

Last night I played 17 tracks of a 23 track playlist before stopping.

This stop was yet another experience since the playback stopped in the middle pf a track but the playlist was not deleted has it was before when stopping mid track.

Another day, another experience.

I am waiting with baited breath for Network Bride II hoping to make my system usable.


#10

I just moved my JRiver 21 library to a QNap TS-251 NAS. I’m running a Direct Stream with a Bridge II. I am having the “one song only” issue as well when trying to stream using JRiver on my PC (via JRemote on an iTouch) from the library on the NAS. I have tried the minimserver streamer and the built in streamer, both with the same result. I tried setting up the JRiver with DLNA on the QNap release. The problem with the QNap version of JRiver is that it doesn’t want to run unless there is a monitor or TV connected to the HDMI out on the NAS and the HybridDesk Station is running on the NAS. I would rather watch sports and listen to music than watch a Jriver interface so I’m not really impressed with the implementation on the QNap. It is supposed to run without the monitor (headless) after it is configured but I can’t get it to work. I also downloaded QRemote for Android to remotely control HybridDesk Station on the NAS and guess what - it doesn’t work either. If I go back to my PC and reload the library on the PC everything works fine. Using the reset UPnp doesn’t appear to apply to the Bridge II as I have never been able to connect to the IP address of the Bridge II.

I just read all of Paul’s posts extolling the virtues of NAS based streaming and I thought that I would give it a try. I certainly agree with Paul’s assessments of control point software.

I like JRiver and I love the sound of the DSD/BridgeII combo. I just wanted to minimize the effect of all of the other processes interfering with PC based streaming.

Any thoughts?


#11

I’m not sure as I haven’t used a NAS in ages but if you are streaming from the PC using JRMC you shouldn’t need the server software on the NAS at all. You should be able to select the folder on the NAS as the library in JRMC (i.e., the folder which it monitors and from which it auto-imports), just like a folder on a USB or internal hard drive. Have you tried that?


#12

No, the OP doesn’t need JRiver on the QNAP; but using it on the computer negates some of the (potential) benefits of having a NAS. I think that JRiver running on a NAS is a recent development and it sounds like they still have some work to do.

More generally, the OP’s experience makes it clear that the problem is not with the server, since all three have the same problem. A few other people have reported the same failure to advance tracks. Have the tech guys at PSA figured out what these situations have in common? Some interaction between the user’s network and the Bridge? I also vaguely remember reading about a setting in JRiver, something like “UPnP next transport event” – but it was a long time ago and I’m not a JRiver guy. Hopefully someone else can help.

lesmcl, there is no web page for B2 (as there was for B1), which is why you can’t connect. B2 has more reliable connectivity than B1 and PSA didn’t feel this feature was necessary.


#13

I was responding to lesmci’s statement that he still has the “one song only” problem when streaming from his PC with JRMC21 from a library on his NAS. The point is in any configuration you only need to run one server. JRMC, depending on the settings, will let you use another DLNA server on the network but there is no need to do so if you can access the files directly, which he can in this case.

I believe the “UPnP next transport event” is one of the two features recommended to turn off when having problems with songs skipping part way through. I think you access both settings by right-clicking the Bridge in the list on the left of the JRMC screen. Those settings are worth playing with to see if turning them off (or on, if they are now off) helps.


#14

Guys,

Thanks for the input. To clarify, I am trying a number of separate scenarios all with varying results, namely:

  • attempting to use JRemote to control JRiver on the PC and just loading the library from the NAS, result is one song only,
  • attempting to use JRemote to control the QNap implementation of JRiver built into the NAS, result is one song only while HybridDesk Station is running on the NAS and then no connection when trying to run headless (no HDMI/display but DNLA configured in JRiver on the NAS) , (FYI - You need a display using HDMI to see the HybridDesk Station interface that exposes JRiver on the NAS to configure the JRiver DNLA and after configuration it should run "headless" without needing a display)
  • attempting to use the QNap implementation of JRiver built into the NAS, running headless (no HDMI but DNLA configured in JRiver on the NAS) and using QRemote to control HybridDesk Station (semi-headless - just made up that expression), result is no connection.
  • attempting to use the QNap implementation of minimserver on the NAS which exposes the Nas library through the minimserver DLNA implementation to JRiver on the PC, result one song only
I am aware of the "Stop after each item" option in JRiver and it is set to "Repeat Off".

My preference or goal is to use the QNap implementation of JRiver built into the NAS in headless mode using Jremote (not to be confused with QRemote on my android device) on my iTouch as the control point. Using QRemote to expose the JRiver on the NAS would be plan B. In other words, ditch the computer.

The commonality in all of the above referenced scenarios is that if I can get anything out of the NAS it is one song only.

Thanks for your thoughts.


#15

I’m stumped. I’m not a NAS guy but the fact that everything works when run from the PC and none of the servers work when the library is on the NAS (even with JRMC on the PC) would seem to point to the NAS but I have no idea what the problem would be. Since you have the same problem with all three types of server software (and JRMC works when everything is on the PC) it doesn’t seem to be a simple server configuration issue (it could be different issues with the various servers causing the same problem but that seems unlikely). Have you tried the QNAP or JRiver boards?

Anybody else out there tried a similar configuration?


#16

Since I use a powerful QNAP NAS instead of the WD Mycloud I have no skips anymore. The MyCloud was so low in processor power and RAM, that due to the overload with various music file update tasks, I guess it even destroyed some files that were unreadable afterwards. It’s lightning fast now, I get 110MB/s (not Mbit/s!) Transfer Speed when copying files and I’m really happy now to be able to listen tracks continuously.

I read above that lesmcl and also chip, althought also having a fast NAS, still have the skipping problems…then I guess there must be a problem with network load…I’d wonder if skipping occurs while you have a fast transfer rate. Or the difference is, that I use Jriver on a PC currrently. But I also did this with the WD NAS and had the skipping I now don’t have anymore.

Unfortunately we still have no clear explanation for the cause of the problems.


#17

lesmcl did you ever get the issue sorted out? It has been a month since you posted. My QNAP isn’t compatible with the JR NAS version but would entertain getting a different one once the bugs are worked out and verdict is in on sound quality. Right now I just stream the NAS library through my Mac.

By this time I’m sure you have done this already, but after I make various and sundry changes to my library, I will also experience the one song only issue. I quit MC21 and restart and everything works perfectly again until I mess around with it. As members here have pointed out to me, making changes in MC often requires a restart to get everything running smoothly. I’m not sure how or if that applies to the native NAS versioin but you never know.