New DS Jr. questions: non-working Bridge, dropouts, etc

Rudy and the Terrible Awful No Good Very Bad Week. Isn’t that a book title somewhere?

After a disappointing week with my phono stage, SUT, and some less than primo new vinyl showing up at Casa Rudy, I thought my newly arrived DS Jr. would be the one bright spot during my week.

No luck! So it has been a head scratcher for three days, trying to figure out what is wrong. Did I not set something up right? Did I have to configure something else first? Was the unit damaged in shipping? (Box is flawless.) Or was something defective? It left Boulder six days ago as of this writing. Here’s the story.

After plugging 'er all in and firing it up, I notice the DS Jr. isn’t showing up on the network. I check the Ethernet port and the status lights are not illuminated, not on the DS Jr. or on the switch that it is attached to. I had unplugged an Oppo BDP-105 moments earlier that was working fine and in fact, I returned the Ethernet cable to the Oppo and everything lights up as it should.

Then I checked version numbers. Here’s what is says:

This was after I ran the update to Snowmass 2.0.1, wondering if something wasn’t loaded correctly for the bridge. The firmware update of course didn’t change anything other than the Snowmass version. I don’t know exactly what “BRDG:None” means, but I am thinking that either the Bridge itself is electrically defective, or the firmware for it was never loaded.

Ironically, when I first powered it up, the selected source was “Bridge.” I can’t even select it from the input selector knob on the DS Jr.–it stops at input 6.

So I’m thinking I either need to load the firmware, or see if the Bridge is bad.

Now, about those dropouts…

I connected the Oppo via coaxial to the DS JR. as I wanted to see if everything else worked–it seems to. Yet I noticed a few times that when touching the volume control if I had a little static on my fingers, the volume would drop out (a very fast fade-out/fade-in). Not a huge concern until it happened when I wasn’t anywhere near the DS Jr. It was just one dropout, but not knowing what causes it, I wanted to make certain it wasn’t something else. (It was an Audioquest digital coax cable, so it should be OK.)

Finally, I’ve noticed that when the volume is up, I hear idle background noise from the DS Jr. It is noticeable when I turn it off–the noise level drops. I keep my preamp up higher, as I prefer the volume control (and the remote) on the DAC. This isn’t normal, since I have done the same with the Oppo for a few years, and never notice a change in idle background noise any time I’ve turned it off. Since I might go with Roon in the future, I would count on keeping my preamp’s volume level up like I’ve done in the past.

I have a note into sales about the issues, but am waiting for Support to get back in touch. Just saving a little time by posting it here, as weekdays are kind of hectic around these parts. And if it helps someone in a similar predicament in the future, it’s all good. I’m hoping it’s all something simple I can take care of at home.

It does look nice sitting there on the rack between my C-J components…but perhaps a little forlorn until the doctors at PS Audio Urgent Care can see what ails us here at Casa Rudy.

I’m not sure how the bridge interfaces with the main board / unit but maybe it or the power to it shook loose on the ride to you? It sure appears as though the main board cant see the bridge.

It seems like there was some chatter about a bridge rescue file somewhere, too. Maybe someone else will be able to help with that.

I did see a Bridge rescue file, but it was a few years old, making me think it is outdated. (I think it predates the Junior, and I wouldn’t expect firmware for it to be the same as the full-sized DS.)

On a computer, I can disable Ethernet ports on the motherboard via the operating system, so that makes me wonder if the firmware for the Bridge was either not installed, installed or configured properly, or was corrupted in some way. I kind of thought that there was only one PC board inside the Junior, but I’m not about to crack open the case to see what’s up (unless they advise me to). I’m no stranger to circuitry, soldering irons and test equipment, but I’d rather not do it on something factory new.

Either way let us know how it turns out and what the issue was. Not fun for you right now but interesting. That’s the bad part of PSA (or anyone) having to use 3rd party hardware or software. It is completely out of their control and anything can happen.

Perhaps a stupid question, but are you sure that you d/l’ed the correct update as I see the Jr & Sr have their own different files.

If so, you might want to see if you can go back to the previous version and see what happens. I had a similiar issue when I upgraded by Perfect Wave’s bridge to the Bridge II, it went from working to not. This went on for three fustrating days, but now for the lige of me I cannot figure out how I got it running again (there were several emails between support and myself, fairly certain I stumbled upon the fix)

No change–it didn’t work when I unboxed it. But I wondered if the upgrade might shake loose whatever bug was hiding in it.

Long shot here, but I had a similar situation where the Bridge II in my DSJr was not communicating with my network, but was fine when the same Ethernet cable was plugged into my Oppo BDP-105D. It turns out that the Ethernet jack where I plug into my network had a single pair of wires reversed, which the technician diagnosed quickly. It seems the Oppo is fine with that particular pair being reversed, but the Bridge II not so. Good luck!

And the dealer who you bought it from, what do they say about it?

Fortunately, I’m working with a router and switches (no hard-wired wall outlets), so the connections are pretty much assured. I had also extended one of the Ethernet cables to the DS Jr. to bypass one of the switches, but, no change, so the cable should be fine.

My one clue something is amiss inside the DS Jr. is that the version is showing as “BRDG:None” on the display. So I’m not doubting my Ethernet connection at this point.

Had a similar message on the DSJ screen after I initially loaded the first version of Snowmass (and Roon also wasn’t showing the DSJ). As I recall, after turning the unit off and on from the rear the proper version of Bridge II appeared. No problem since then.

It sounds like you may have something else going on, if your Ethernet status light isn’t on. Still, of course, try the easy stuff first. Also, consider downgrading to Yale and then reinstalling Snowmass.

No Ethernet lights at both the switch and the DS Jr. tell me there’s either a problem with the cable (which is ruled out), or an inactive Bridge. From what I’ve read last night, I wouldn’t even be able to load Bridge firmware without already having a connection to begin with. (Can’t do this via USB, apparently, which is the only way I can see loading anything if Ethernet isn’t functioning.) I’m pretty much convinced the Bridge itself is electrically bad, the more I read about it.

Shouldn’t this have been tested before it even got packed up and shipped from PS last Monday? Apparently not. I feel like I bought a Heathkit that someone assembled 95% of the way…

You could try the downgrade to Yale, upgrade back to Snowmass and see if that does the trick . . . .

Have you tried downloading a different version of the Bridge? I once messed up reverting to a previous Bridge version and my DSJ read as having no Bridge. When I did it again, the Bridge reappeared. PS Audio will guide you. I forget the exact steps.

I’m not doing anything further until I hear from Support. It’s been reported since Thursday, but no response as of yet. I don’t have time to go through all this nonsense of loading every different firmware under the sun to see if it will work.

Hope it gets resolved quickly and you can post the follow up: Rudy and the Awesome Week of Music with No Annoying Issues!

1 Like

It should have been tested. But problems with brand new stuff not working properly out of the box seems to be an often reported occurrence. It’s also happened to me several times. Just return it for another one.

An RMA and call tag are coming my way tomorrow morning–I was emailed a set of firmware to try this afternoon, but it didn’t change anything. So I’ll have another Junior on the way to me soon. :+1: It was packed quite safely, but I still wonder if something got knocked loose along the way.

1 Like

While only anecdotal, if there’s no Ethernet cable (or I assume an incompatible cable, if there is such thing) connected to the DSJ, it will read “BRDG: None” as well.

It should work out of the box perfectly without having to mess with anything. I hope the replacement does just that.

I’m glad to hear our service team was able to help you out :+1:

We test every single product before it goes out, but networks are complicated things and FedEx isn’t always nice with the packages they deliver.

I’m looking forward to hearing how things go once the replacement arrives!