Power Plant P3 Firmware Update


#1

Has anybody tried a firmware update on P3?



I assume copy firmware files to USB, load and reboot P3, new firmware sticks.



This doesn’t work for me. When the P3 reboots I see “InI P3” on the display for about 3 seconds, then the display goes blank. Wait. Wait some more. Turn on P3. Check Web UI and it reports the previous firmware.



What am I doing wrong here?


#2

The P5/P10 update is not intended for the P3.


#3

Yes, I know. I’m trying to load the new P3 firmware that PS Audio sent me on to a P3.


#4

I received an email about a firmware update being available for my P3 but I can’t seem to find a download source for it. Is there actually an update for the P3 or just the multi-wave update for the P5 & P10? Thanks!


#5

There is an update but I’m not sure if it’s a public release yet.


#6
brodricj said: I'm trying to load the new P3 firmware that PS Audio sent me on to a P3.

O, Ho!

Unzip the file on your computer and place only the unzipped files on to a USB drive. Turn off the P3. Put the USB into the back USB port. Turn on the P3. As I understand it, this will load the new firmware (I do not have personal experience with a P3).

My suspicion is the unit want to see a USB flash drive formatted to FAT, not FAT32 or NTFS.

#7

Can anyone tell me what the P3 firmware update is intended to fix/improve, and where I can find it?



Thanks


#8

I’m still wondering the same thing and perplexed as to why this is so “mysterious” and difficult to get an answer to after a month and a half… either there is or there isn’t an upgrade to the P3 firmware. If there is an upgrade, I’d also like to try it. If there isn’t an upgrade, I’ll let it go. Could someone from PS Audio please chime in? Thanks in advance!


#9

There is no update for the P3 I am aware of. The update for the Power Plants was for the P5 and P10 only. Can you let me know how it is you were told it was for the P3?



Sorry for any confusion.


#10

PS Audio CS sent me a new firmware for my P3. It wouldn’t load into my P3 (hence my originating post). P3 returned to factory to have firmware files loaded. I’m told the P3 will ship back to me this week.


#11

The Downloads page Download Products Update tab appears to have a P3 update named .15 USB Install. When I click on it I just get a picture popup - no software download.

Is there supposed to be a P3 update we can download to a USB flash drive?


#12

Oops. Let us get that fixed. Sorry.


#13

Ok, all fixed up. Missing link. Thanks for the heads up. party_gif


#14

Thanks for the fix. Now I just need a working P3. The remote control function stopped working and I am waiting on an RMA (customer service did send a new remote - that was not the problem). Once I get the P3 back I will do the update.


#15

Hi, I just noticed the new .15 update so I copied the files in the ZIP file to a freshly formatted USB stick (tried both FAT and FAT32) and followed the FAQ on how to update. After turning the P3 on using the switch on the back it seemed it was updating as power to the connected devices only turned on after a few minutes. However when I logged in to Powerplay the site still displays: Firmware Version: 0.00.12

Did it update or not, how can I check? What has been addressed in this update?


#16

No reply here, no reply from PS Audio support as well after an email. Great after sales/customer support PS Audio… :( I’m now just hoping that no real issues ever arise in my P3 or Dectet.


#17

Sorry, I don’t see all the posts every time. Contact us at support@psaudio.com and we can help.


#18

Thank you Paul. On the 25th of May I emailed support@psaudio.com and today Alex sent me the most current version of the firmware/update files and now everything went exactly as described. So I guess the version I downloaded recently has an issue that has been resolved in this most recent version.


#19

So has the mystery been solved? What does the P3 firmware update do? If I download the update from the web page, is it the correct update?

Thanks!


#20

P3 update named .15 USB. Anybody know what this is for?

Thanks, Dale