Problems with forum after website upgrade

Some details on username/passwd. Follow Scotte1’s advice, it works for me as follows:

  1. For forum username/passwd, I was using my email as username, but the forum site no longer takes email as username for (re) signup, So, I try to signup with my forum name, it says “name has been taken”, so I signin with my forum name, but it won’t take my password. After a password reset, I rcvd reset email, and complete the process.

  2. For PSA website (for Powerplay, prod reg info etc), it can take email as username, but trying to signin with my email, it says “username does not exist”. So, I (re) signup with my email and passwd. Rcvd account activation email, and finished the signup process.

After all these, all my stuffs are back, nothing missing. :slight_smile:

1 Like

I need a third account to actually comment on a Paul’s Post?
With Disqus directly?

Which then opens in a limited pop up which, because of the limitations, cannot disable No-script which is probably why:

"Could not connect to the reCAPTCHA service.

Please check your internet connection and reload to get a reCAPTCHA challenge."

I hate the internet.

(I don’t, it’s fab, it’s the humans that program it that need a good talking to).

Ah well :slight_smile:


Hi, I’m having a similar log in problem. Since June 2024. The Forum page no longer has a log in button. I have tried to reset my password as the site suggested but did not receive an email to help with this.

Have you tried clearing the browser cache?

1 Like

Noticed the same issue months ago with the no login in icon using my ipad. Swiping the screen down would sometimes uncover the login in icon from under the top task bar but not long enough to activate it before it popped right back up. I messed around and found if you open a topic and attempt to Reply to an entry, it will give you the login in screen since you have to be logged in to reply. I always use the iPad so wondering if this happens when using a phone or desktop.

Funny, this constantly happens on my IPad but is just fine on my IPhone. I need to use the IPhone to reveal the avatar/personal message area. Frustrating.

It seems only iPad has this issue. I cannot do search on it but could do that on laptop and phone.

Wait! PSA may have fixed it just now…

Edit: not fixed!

Same issue here on iPad can’t access the SEARCH button on the right corner menu

But can you see your avatar/ pm indicator in the upper right? I can see it briefly in a quick scroll but then disappears. Weird.

1 Like

With an android you still can’t see the name of the topic at the top.

But you can on other Discord forums such as dCS.


I suppose to know Franco, is this a coincidence?

1 Like

The world is this big:


It all fits in there.

1 Like

Silver and dCS, Franco is alright by me. The next time you see him, please buy him a glass of Brunello di Montalcino for me.

Grazie amico mio!

1 Like

I had a call with him right a few days ago! He asked me about Tempus and Muon Pro and wanted to convince me trying EntreQ grounding boxes. He’s a nice guy! How a small world indeed!

I’ll tell him about you for sure next time…

1 Like