PS Audio AirLens

James, Thanks for the input.

i would assume that’s the entire argument FOR the airlens, in that it would be better

Well - not everyone has the luxury of putting their Roon server next to their DAC and can connect via USB.

So maybe the question should be:

What do you like better: USB connection directly from the Roon server or I2S connection from an Airlens that is connected via ethernet to the Roon server?

oh totally, but I think the selling point of the airlens (and other streamers) is that they improve on the sound of a computer/server as the streamer


At least in my system, the MKII does such a good job of isolation on the USB input now, the Airlens is overkill. But others may find it different. Direct connection from a NUC/CORE is very noisy, so maybe even the MKII could not keep it all out. I have not tried this combo. But from all the streamers I have tried (800-1500 range) they are seemed super similar with the MKII to my ears. Nothing made me say I have to have this one over that one.


I have both setups, and I can tell you that in my system, Roon Nucleus+ > AirLens > I2S versus Nucleus+ > USB to the DS Mk2 is almost too close to call.

The AirLens chain is router > JSSG Ethernet cable > EtherREGEN > Wireworld Red Ethernet > PhoenixNET switch > Synergistic Atmosphere Reference Ethernet > Nucleus+ > Wireworld Platinum Starlight 8 Ethernet > AirLens > Wireworld Platinum Starlight 8 HDMI I2S into DS DAC Mk2.

The USB chain is router > JSSG Ethernet cable > EtherREGEN > Wireworld Red Ethernet > PhoenixNET switch > Synergistic Atmosphere Reference Ethernet > Nucleus+ > Synergistic Atmosphere Reference USB > Uptone ISO Regen (Sbooster powered) > Curious Evolved Link > HDMI I2S into DS DAC Mk2.

I marginally prefer the AirLens setup, but I’d be hard pressed to tell you why, other than the fact that I’ve spent so much more on the AirLens chain!


I’ve run the tests between or Roon NUC via USB and the AirLens over the LAN and hands down it’s better through the AirLens.

Leaving the computer where the Roon server is running isolated by itself and then onto the home network is always going to be better than a USB connection.

1 Like

Interesting observation…

I always use Ethernet for streaming to the audio system and the TVs in the house, and I’ve been streaming nicely to the AirLens since Saturday.

However, if I had to use WiFi on the AirLens, I can’t see any way for me to enter the SSID (as I don’t broadcast it) and enter a password. The only option I see is to connect using WPS, but the enterprise-grade networking hardware (access point) I use does not offer WPS. (Namely, the UniFi U6 Long-Range. At this level of hardware, WPS is a security risk for various reasons I won’t debate here.)

Is there another way to enter the WiFi information? Even if I had to enter it while connected through Ethernet (which is what I have to do with my surveillance cameras), that would work. But I’m not seeing it. I would not expect to be able to do this through the mconnect app, as it appears this only works with the audio side of the AirLens.

The only workaround I can see that might work is to find an old consumer-grade router that has WPS, set to the same SSID and password as my access point (which I’d have to disable), program the AirLens through WPS to connect to the network, then remove the consumer-grade router from the network and reenable the access point. Seems like a bit of a chore though, and that’s more expense and clutter to deal with. (We’re downsizing and the old stuff is supposed to be leaving the house, not entering! :grin:)

1 Like

There is but I would have to reach out to our engineer to figure that out. Let me see what I can do.


It’s no rush–just a curiosity at the moment! But I think there may be others who don’t have WPS and might be at a loss on how to connect if they can’t use Ethernet.


can you temporarily broadcast your SSID, just to connect to the AL? (Then unbroadcast it once you’ve connected?)

1 Like

good idea, i almost forgot i used this once and it worked in my case (don’t remember the device).

I just spoke with our engineer and here was his reply: There is a way to directly enter an SSID using the airlens.cfg file. It’s currently undocumented. The best option is for him to call customer service and they can help him with it.

Hope that helps.


@Paul I think PSA should document this asap. WPS is not the most secure method and many new mesh routers do not support it. Something simple like the a file as you mention above. Of course we would all love a web interface at some point.


I would be interested in knowing how to do that too.

I’m back home and had a chance to play with the AirLens a bit more. The MConnect Control HD app (for iPad) was still not finding the AirLens so I contacted Convers. The reply was to try the other apps. I did and no difference. So out of curiosity I tried running the ethernet line to my Orbi instead of the ISP gateway, success! Apparently there is a communication issue within my network here. To explain, I have AT&T UVerse fiber, the provided gateway (which must be used) has wi-fi, but it didn’t work well in my house so I got an Orbi Mini mesh system. When I had the DS with Bridge II, I just had the gateway wi-fi shut off and everything worked. Recently I read I should put the gateway in DMZ mode when using the Orbi. I did this and have been having some issues ever since. The important issue is communication (via wi-fi and my iPad) between MConnect and the AirLens was not working. I fiddled with the Orbi and gateway settings to no avail. Strangely I could communicate with JRiver/JRemote.

Now that I’ve got the AirLens working I should be happy, but no, I would like to go direct to the gateway, any ideas on what setting to change? I am not an IT type, but I sometimes fumble my way through this stuff with some hints!

That still leaves no way to connect as there’s no WPS capability on the access point. Plus, I’m short-ish. I’d need a ladder or drywall stilts to reach it even if it did have a button. :grin:

It’s not too big of a deal to turn on SSID temporarily though. But the ability to enter SSID and password are usually standard fare in other devices I’ve set up on the network, which is why I thought I’d ask.

There are a few really lightweight web server options available, but there may not be a full-blown OS in the AirLens to support it.

1 Like

A few things I’m noticing…

  1. Ticks when switching between DSD or PCM sources. And going from DSD :arrow_forward: PCM sometimes clips off a portion of the PCM track. Not a huge issue but will probably be fixed in a future firmware update, I’m thinking. (If a track is slightly clipped, I just restart it and all is good.)

  2. UPnP/DLNA for the AirLens is not appearing on the network. I have other DLNA renderers in the house and they show up on the list, but not the AirLens.

  3. The mysterious 8th DIP switch. :grin: DIP 7 is related to firmware updates and factory resets. I searched the manual but nothing on DIP 8.

  4. When I first got the AirLens, the mconnect app could access the AirLens. Lately, it can’t. But I need to power cycle the AirLens to see if that fixes it. (It’s low priority and yeah…I’m getting older and forget things way too often!)

This can also depend on whether or not there is any network hardware between a NAS and the AirLens. In my case, my two NAS boxes plug directly to the router (whose ports act as a switch), and from there it passes through three more switches before it gets to the audio rack. (One router port goes to an 8-port switch where it then gets distributed through the house. Switches in each room with more than one Ethernet device then distribute one incoming Ethernet connection as needed.)

With one or more switches in the path, those might be enough to keep a live Ethernet connection to the AirLens even if the NAS is powered down.