PST Owners: Need feedback on an issue I am having

I have had my PST about 2 weeks and I noticed an ongoing issue with mine. I was wondering what it does on yours when you go to play a CD under this scenario…

Open the drawer, insert a CD on to the tray and press the play button (center button of the option wheel). I get 3 different responses when doing this:

  1. Drawer closes, reads CD and nothing happens. This happens the majority of time.

  2. Drawer closes, reads CD, a few seconds of the CD plays and then stops. Happens occasionally.

  3. Drawer closes, reads CD and the CD plays normal. Happens occasionally.

Most CD players will always do #3 every time.

Is what I am experiencing a bug in all PST units or just mine? I have played a lot of CDs over the past 2 weeks, so I know it is an issue and very annoying.

No, the play on the wheel works fine, but the remote has a problem. Tapping once doesn’t work. I have to tap twice quickly, then it responds. Try tapping 2 times quickly on the play button and see if that works.

1 Like

Thanks for your feedback. I just tested that based on your experiences. I double clicked on play on the wheel and play on the remote 5 separate times each. It only worked once on the wheel and twice using the remote. All the other times it played for a couple of seconds and stopped.

How about resetting the unit by the switch on the back? Sometimes if the unit is unresponsive rebooting the unit might help.

2 Likes

With your suggestion, I may have figured out the bug or at least part of it.

After turning off the switch in the back and turning it back on, pushing play worked 5 times in a row. However, only worked 2 out of 5 with the remote.

Then, I put the unit in the standby mode by pressing the PS Audio logo and left it off for a minute or so. After turning it back on with the standby mode button, pressing play within the wheel never worked in 5 attempts. Always played for a couple of seconds and stopped. Oddly, the remote only worked 2 out of 5 tries again.

Seems like the standby mode is the part of the main bug of pressing the play button within the wheel and it not working. I will continue to monitor it throughout the weekend to see if it continues to work or not.

The remote problem may be a related, but separate issue. However, the remote play function does not consistently work no matter what.

Maybe James can chime in if these are known problems at PS Audio or if a bug fix is already in the works.

Looks like some kind of software glitch. @jamesh the Whiz Kid should be able to set it straight.

1 Like

Happens in my PST during beta testing. It contributed to

  1. the disk was not place properly in center.
  2. Dirty disk.

Other glitches on my unit are bugs and have been fixed via subsequent FW releases. Current release 2.4.2 fixed a bug I have.
Might want to verify if your unit has FW 2.4.2. If so, these abnormal behaviors might need to have PSA takes a look.

1 Like

Thanks Terrence for your input. My PST came with 2.4.2 installed.

On the points you made:

  1. I have experienced the CD not being centered issue a few times, so I am aware of that issue. As I recall, you get an error message saying it could not read the CD.

  2. I am a bit OCD about dirty or marked up disks, so I know that is not the root cause of the issue.

You have perfectly described the way mine works. I’ve just been dealing with it, assuming that the design was removed from the oven before it was was fully baked and hopefully it will be taken care of with updates.
Sounds mellifluous, though.

1 Like

I have noticed similar behavior and am also a long time “press play” once type of guy. I’ve gotten used to it a bit. I now press the button twice or whatever. I think my default routine is press close, and press play after it reads.

1 Like

I appreciate all the input. I am glad to find that it does appear to be a bug and not just my unit. I am enjoying the sound quality, so no complaints there.

Maybe I am being a bit OCD about a functionality issue. However, it seems like this issue that should never had made it out of beta testing, since it is such a basic function of any CD player/transport. Hopefully, PS Audio is aware of the issue and is working on a solution.

This came up once before, and James said this is not a bug, but the way the software was designed. With the DMP, if the display was turned off, remote commands worked with one push, this is not the case with PST. If the display is turned off on the PST, remote commands require one push to wake the screen up, followed by a second push to compete the command.

I just sent Barry a note and hopefully we can make it work more consistently!

1 Like

I’ve also experienced the occasional “no read” of the disc and wonder if the clunk of the drawer closing is part of the reason, in that the disc slides a bit out of the valley on the tray.

Just confirmed that the buttons on the PST operate the same way as the remote. If the player is in standby mode with the display turned off, it requires two pushes of the play button. This is not a bug, it’s how the software was written.

If the display is on and out of standby mode, you can load a CD hit play and it will play.

It sounds like others are getting the same behavior but only sometimes. Does it work this way for you every time?

I’ll have to test it out over a period of time. That was the first time I used the buttons on the transport, only use the remote.

My PST seems to consistently require a double push on the player or remote to play.
In the back of mind is a thought that during beta this was to be addressed but recently it
was determined that it was inherent in the design.

After more testing I found when you turn on the main switch on the back and then pressing the play button within the wheel the PST works properly. It does not work the same when after being in the standby mode. The issue seems to be when coming out of standby.

That could be why I don’t have a problem. I never put my unit in standby mode. Instead I just dim the display.
Maybe do that as a temporary work around.