PWD 2.4.4


#1

So how many have downloaded and installed 2.4.4?

I have been running it for a few days now…

And while the number and ‘severity’ of the pops and clicks are indeed reduced, they remain in some situations.

I have not heard any change in SQ, at least thus far.

The ‘acid’ test will be when I revert back to 2.4.3, just to see what if anything changes.

JJ


#2

Hi, the main differences between firmware 2.4.3 and the latest version, the 2.4.4?
I did not find any changelog here.

I would also like to ask who owns the “bridge” in combination with Pwd mkII, which is the combination of firmware that works better, both listening in the management of files from Nas.

Currently I have downloaded the software “Plug Player” on my iphone 5, to be used instead of proprietary software Elyric Controller”.
I found a very good operation, except for a small bug: the stop button does not work (on Plug Player). Maybe it depends on the firmware version of the bridge?

Thanks to those who want me to answer.
Congratulations to Paul and his group: continue to work well. I’m always looking forward to more news (such as the Bridge II smile).

Marcello


#3

PWD-2.4.3. or 2.4.4

BRIDGE- 2.13c

edit:

many are having good SQ results after installing 2.15a for the Bridge.


#4

Good job PSA, no more clicks in the first audition. Played between HD and red book several times and no clicks. SQ is excellent.41_gifsmiley-music005_gif


#5

Could others check to see if the mute function is working on 2.44?

Mine visually shows muted, but music plays on…

sounds great, but…

Thanks,


#6

No mute from remote control here. I never use it, goin through a pre. But it can be an issue for those connecting direct to amp.


#7

Like me!

any others?


#8

I haven’t fully checked out 2.4.4 but it has issues like other versions.

The old problem of music playing when the unit is off for example.

My unit won’t mute with the remote either.

I always get pops when changing up a playlist or selecting a track after nothing is playing. I haven’t had time to see if that is JRiver or just this FW. One of these days…

Sound quality is fine.


#9

I see this problem referred to in the December 2013 2.4.4 beta test topic.

PS Audio, can you fix this or should we roll back to 2.43?

Thanks,


#10
audiobill said

I see this problem referred to in the December 2013 2.4.4 beta test topic.

PS Audio, can you fix this or should we roll back to 2.43?

Thanks,


Yes buy the new DSD at the same price of the PWD II and the problem is solved!!!

facepalm-smiley-emoticon_gif

Otherwise, probably in 2019 you will enjoy the DAC without pops

F.


#11

Hi,

Version 2.4.4 is not in the DOWNLOADS portion.

Can anybody send me a link to download it ?

Thanks.


#12
amiglic said Hi,

Version 2.4.4 is not in the DOWNLOADS portion.

Can anybody send me a link to download it ?

Thanks.

It’s not there, don’t know why. Maybe some one at PSAudio can check this?.

A few days a go the clicks returned and they are gone again, weird…

DS Kit is here so my PWD will soon transforms into a DS!smiley-music005_gif


#13

2.4.4 is back on the product downloads page…


#14

Trying to keep up with you guys!


#15

LOL!


#16

@adminpaul: are there any release changes for PWD fw version 2.4.4?


#17

I’m trying to update my PWD Mk2 from 2.2.0 to 2.4.4. No go. When I power on as usual the unit initializes but does not go through any sort of upgrade. Any thoughts?

Thanks


#18

I am also not the update to perform in a position to 2.4.4 on the PWD II. I use each 2 blank SD card, 2 GB. Just as with mikec.

What am I doing wrong?

friendly greetings

kdieter


#19
mikedc said I'm trying to update my PWD Mk2 from 2.2.0 to 2.4.4. No go. When I power on as usual the unit initializes but does not go through any sort of upgrade. Any thoughts?

Thanks


What upgrade method are you using? You may need to do a USB upgrade.

#20

Re PWD firmware update problems.

1/ unzip ONLY the contents to an empty sd card. [ empty the card and empty your trash bin before reloading].

2/ the SD contents MUST be a different version than the one already on the PWD.

3/ also try loading a different version and then redo the update to 2.4.4.

if the left front PSA logo button flashes, then it is updating.