PST occasional quirk

I notice that on the rare occasion my PST will stall with a disc inside and the power button on the upper left front of the player will be flashing. The only way I can retrieve the disc is to power down and then start up the player and the disc will be released. This has only happened a couple of times and I attribute it to possibly finger prints or such on the disc. Is this normal?

This thread may be of interest:

This is a known problem on my PST.
Long time ago, PST developer told me that logo flashing means the PST has encountered a fatal software error.

This problem was almost fixed by FW2.4.4.
It only happened once after the FW2.4.4 update on my PST. Here is my PST log entry on this incident.

PST failure - logo flashing FW2.4.4

03/20/2022 12:02PM

During the CD play back at track #3. PST hits the usual fatal error symptom - PSA logo flashing, all ctrl die.

Usual treatment, wait till CD plays to end, main power cycle seems reset PST back to normal.

Not many of you have tried this, I think. But in case you do this on PST, it will have a high chance to throw a tentrum and stop working.

I burned a mixture of AIFF files and DSD files into a DVD disc. Whenever I played it, PST would either stop or skip the DSD files. Today it not only stopped, but it also affected DS MK2. I could not make it play discs nor streaming. The only cure was to unplug both power cords from PST and MK2, and waited for a couple minutes before pluggend them in again. A total shutdown finally worked. I threw the disc away.

When playing DSD or AIFF discs only there are no issue.